[SOLVED] Use WiFi over Ethernet for internet, but the other way around for local file sharing?

Achint2000

Distinguished
Feb 10, 2013
692
1
19,165
90
I have a desktop and a laptop, and I prefer 1 Gbps transfer speeds for local file sharing when my laptop's sitting on my desk.
My WiFi Router is 100 Mbps only, but is the main source of internet access.

Both systems are connected directly via LAN, 1 Gbps link speed, fixed static IP addresses and gateway. Mapped network drives work perfectly, I can stream movies and even play some non disk-heavy games which get directly accessed via LAN.

Problem starts, when both systems are also connected to the same 100 Mbps WiFi Router as well.

I had to force a high interface metric for LAN so all programs access internet over WiFi and share files via LAN. This worked well as long as both systems weren't connected to the same wifi.

As soon as they both connect to the same wifi, mapped network drives switch to being accessed through wifi router instead of LAN because of the forced high metric on LAN, and speed gets 10 times slower.

While copying files over shared network, resource monitor reports System (ntoskrnl.exe) to be the process through with data is transferred.

I don't want to use ICS or something like ForceBindIP, I want to set up PREFERENCE ONLY -- When LAN connected, share files over LAN but access internet through WiFi, otherwise use WiFi for both anyway.

Any idea how to set preference like this? Or any alternative solutions?

Here's a quick MS Paint image of what I want -

Programs like Chrome, Discord, etc to access internet through WiFi
Local file sharing through Ethernet


Thanks!
 
Use a completely different subnet for the lan network. Do not configure a gateway or dns.

It will use the wifi for everything except IP on that other subnet. You may have to be careful to use the proper IP address since both machines will have IP on both networks.
 

Achint2000

Distinguished
Feb 10, 2013
692
1
19,165
90
Use a completely different subnet for the lan network. Do not configure a gateway or dns.

It will use the wifi for everything except IP on that other subnet. You may have to be careful to use the proper IP address since both machines will have IP on both networks.
I tried that but for some reason, the traffic still goes through the slower wireless link. I have to manually disconnect either device from wifi, open one of the mapped drives for it to start accessing the drive through the direct LAN link. No default gateway is configured, just the IP addresses.

Put both systems on a 10/100/1000 switch.
Any traffic between the two only goes to the switch and back, at gigabit speed. Not up to the router.
The whole point of using a direct LAN-LAN connection was to avoid buying new hardware... there must be some other software way to do this?

If I have to buy something, might as well buy a new gigabit router, and connect both systems to that. It would be much easier because both systems will have exactly one link to each other, and I can add a third system if I need to in the future too.

 
Not sure why 2 networks does not work people do this all the time.

Be very sure you have 2 completely different subnets and you do not have gateways on the ethernet. Next you must use the ip address on the ethernet to force it to use the ethernet. Many times if you use the name of the machine it might use either connection.
 

Ralston18

Titan
Moderator
Question:

I am wondering about the make and models for the desktop and laptop.

In some cases, as I understand it, plugging in an Ethernet cable disables wireless.

That "feature/function" (if available) can be disabled via BIOS so both wired and wireless are available simultaneously.

Not something that can be done via Windows or network adapter configuration settings if I am following correctly.
 

Achint2000

Distinguished
Feb 10, 2013
692
1
19,165
90
Question:

I am wondering about the make and models for the desktop and laptop.

In some cases, as I understand it, plugging in an Ethernet cable disables wireless.

That "feature/function" (if available) can be disabled via BIOS so both wired and wireless are available simultaneously.

Not something that can be done via Windows or network adapter configuration settings if I am following correctly.
Desktop Specs (self built):

i7 7700k OC 4.8 GHz
32GB GSkill Trident Z (4x 8GB) RGB 3200MHz XMP
ASUS Strix 2080Ti o11G
Corsair RM1000x
Noctua NH-D15s
Windows 10 v1903 / Windows 7 SP1 (dual boot)
TP-Link PCIe x1 300Mbps Wireless N Adapter (WiFi)
Intel Gigabit Ethernet

Laptop:
[ASUS Strix G531GT]
i7 9750H default turbo @ 4.1 GHz
16 GB RAM
GTX 1650 4GB
Windows 10 v1903

Plugging in ethernet doesn't disable wireless or anything. It functions just normal and both are enabled at the same time.
 
Achint2000 said:
I tried that but for some reason, the traffic still goes through the slower wireless link.
Go into the router settings and enable Wifi "isolation." That prevents Wifi devices from seeing each other but still allows internet access.

In the advanced Network Connections settings (the one where you have to hit the Alt key to show the advanced menu in Windows 7-8, or under TCP/IPv4 for Windows 10) there are arrows to set the adapter priority so the top adapter will always be tried first, in your case the Wifi which is fine. You just want it to failover to ethernet, which is simplest with the isolation setting of the router, as it would then be completely automatic.
 

Achint2000

Distinguished
Feb 10, 2013
692
1
19,165
90
Go into the router settings and enable Wifi "isolation." That prevents Wifi devices from seeing each other but still allows internet access.
Thought of this as well but I have two android devices which I use to stream movies and TV episodes using the same windows shares method from the same desktop and the same WiFi network... if I enable AP isolation, that won't work either.

At times I'm also using one of my phone's wifi hotspot where both devices are connected, and that doesn't have an AP isolation option.

In the advanced Network Connections settings (the one where you have to hit the Alt key to show the advanced menu in Windows 7-8, or under TCP/IPv4 for Windows 10) there are arrows to set the adapter priority so the top adapter will always be tried first
Found that in Windows 7 and changed the priority of LAN first. Since LAN has no default gateway configured, internet still works through wifi just fine. But it still doesn't work! It still accesses through wifi.

For Windows 10 and 7 both, I already had changed the metric settings for LAN to 1 and WiFi to 9999 but it still accesses through wifi first ._.


The only temporary solution that works, is to disconnect a device from wifi, open network drive so it finally accesses through ethernet and then connect to wifi again. But after a while, it again just switches back to wifi for those drives. This is too annoying.
 

Ralston18

Titan
Moderator
Duly noted: "The whole point of using a direct LAN-LAN connection was to avoid buying new hardware... there must be some other software way to do this?"

"Too annoying" is also understood.

And I truly appreciate your desire to work with what you have and not need to buy more hardware.

But the software solution is cumbersome (as you state in the preceding post) and likely to come undone for one reason or another.

Overall, there is a lot to be said for simplicity (aka Occam's Razor's to some ways of thinking).

I.e., per @USAFRet (Post #3).

"Put both systems on a 10/100/1000 switch.
Any traffic between the two only goes to the switch and back, at gigabit speed. Not up to the router."

Simple and easily done.

Never let form get in the way of function. Buy the switch and go forward.
 
The only temporary solution that works, is to disconnect a device from wifi, open network drive so it finally accesses through ethernet and then connect to wifi again. But after a while, it again just switches back to wifi for those drives. This is too annoying.
Access shares by ip address (not by host name). On wifi network ip addresses are different from addresses on pc-to-laptop connection.
 

Achint2000

Distinguished
Feb 10, 2013
692
1
19,165
90
When you map network share, you specified \\pc-name\share-name
Use ip address on wired network instead \\ip-address\share-name

You can get ip-addresses with ipconfig /all
The last time I tried, I was using THREE slashes instead of TWO ( \\\192.168.2.101\ )

Doing that the correct way:

This PC > Map Network Drive >
\\192.168.2.101\WindowsDrive
\\192.168.2.101\BackupDrive
\\192.168.2.101\Music&Movies

Worked instantly!
Finally a software solution that'll work ^^
Thanks!

And thanks for all the help everyone :)
 

Achint2000

Distinguished
Feb 10, 2013
692
1
19,165
90
I want to set up PREFERENCE ONLY -- When LAN connected, share files over LAN but access internet through WiFi, otherwise use WiFi for both anyway.
I don't think any software trick would work when it comes to this part ^

If my laptop is off the desk and I need to access the same drive via wifi, I have to map it again and change the IP address to the share name everywhere...

Never let form get in the way of function. Buy the switch and go forward.
"Never let form get in the way of function" -- well said...

One of the gigabit routers I was looking for was on discount, and that router has 5 GHz support too, means faster LAN transfer even on wifi with my laptop (around 800 Mbps). The ISP provided one I have right now lacks some features I needed as well.

So I'll go with buying a router anyway.

Again - Thanks for all the help!
 

ASK THE COMMUNITY