Question Used i7-6700K Does not Boot

Just bought this one on eBay for $200 and the seller said it worked fine when he pulled it. It looks fine but doesn't boot. Everything powers on but no display, no keyboard function (num lock), tested on two different working systems (both Z270) and the CPU doesn't work on either.

I've tried resetting bios and multiple display configurations (GPU and iGPU).

The CPU is cold after the PC has been on for a little while. It just seems dead but there is no apparent damage and the factory seal appears to be on the lid (IHS).

What could be wrong with it and/or what could I do to test it further?
 

Lutfij

Titan
Moderator
You could delid it and see if the processor has been tampered with. At this point of time, I'd either return to seller, rid myself of any worry or junk and to be double sure, source a 100 series chipset board(Z or B) and see if that works on those boards. Might also want to inspect the contact pins on the processor.

There have been some folks I seen on OCN who got scammed with a lesser processor using an IHS from a higher model.
 

ASK THE COMMUNITY

TRENDING THREADS