Question used RAM fried Mainboard or CPU, debug help needed

Jan 9, 2021
1
0
10
0
Hello,

I would appreciate any help on debugging my system and finding out what happened today.

System info:
AMD R5 1600
MSI B550 Gaming Plus
Other stuff should be irrelevant, but just ask if sth is missing. Don't wonder about the first gen Ryzen in a B550, this is running fine in most B550 boards and that was the case here too.

What happened:
I was running two sticks of old 2.666MHz DDR4, so I wanted to upgrade as RAM is said to have a big impact on Ryzen performance. I got used 3.200MHz RAM from a friend, I trust him and he told me he had it laying around as he himself upgraded over a year ago.
On first boot with those sticks the CPU light on the motherboard lit up and there's three long beeps.

What I tried so far:
I tried booting with the old RAM and with individual sticks of both kits in different slots. Nothing changes, always CPU light + the beeps. I did a cmos reset and tried the same, nothing changed.
Sadly that's my only system BUT I have the old X370 motherboard lying around.

My questions and stuff:
Did defective RAM fry my motherboard? Or my CPU? How could that happen? My understanding is that even if there's a short on the RAM, that voltage shouldn't be able to fry anything. Only explanation would be static discharge, but I usually work with one hand on the grounded chassis and didn't feel/hear anything.

I could try the CPU and old RAM in my old mainboard but I am in fear of frying that as well. I still need it.

Thanks for reading that far...
 

ASK THE COMMUNITY