Question Used RX 580 not possibly working

Jun 23, 2019
17
1
15
0
Hello everyone, I recently bought a used RX 580 from a site, I asked my friend to go to another city so he can pick up the GPU, he came back a few days later, and gave it to me, installed the GPU in and plugged in the HDMI cable, i turned on the PC, and there is no signal, so I used intel integrated graphics, and checked Device manager, and there is no RX 580 in the Device manager. What could have I done wrong? I will post pictures tomorrow of the GPU. The GPU is a MSI RX 580 8G Armor OC. And if it matters, I had a Sapphire RX 570 4G Mini ITX Installed and it worked fine. And I have uninstalled the drivers before installing the RX 580.

Edit: I have checked Task Manager and there is no RX 580 in the performance tab.

Thanks
Zelion
 
Maybe the USED GPU which you bought was faulty, in the first place, so that's why the seller sold it second hand ? Always verify the seller's reputation when buying second hand cards, this is assuming he sold you a faulty/defective GPU.
 
Jun 23, 2019
17
1
15
0
Maybe the USED GPU which you bought was faulty, in the first place, so that's why the seller sold it second hand ? Always verify the seller's reputation when buying second hand cards, this is assuming he sold you a faulty/defective GPU.
The site doesn't have a reputation system, I asked the guy if it works, he said yes, I also asked if it was mined, he said no.
 
Jun 23, 2019
17
1
15
0
Did you connect the PCIe connectors to the card?

Did you try other outputs besides the HDMI (assuming your mother supports those other outputs)?
It does have display port and DVI-D but my monitor only has HDMI and VGA, but I'm thinking of getting an adapter, also I forgot to mention and I turn on the GPU the fans don't even spin, it does have a feature to only spin when it's 65 degrees and more, but it does have to spin at start-up atleast
 
If you can borrow (or get for cheap) a DisplayPort to HDMI adapter, give that a shot.

The only reason I say this is because my brother's video card started giving him issues, and switching from the HDMI out to one of the DisplayPort outputs solved the problem for him.

Similarly, I've read a few posts here and there where it seems that one of the output ports on someone's video card had gone bad, but the other ports were fine.

It's a long shot, but it might be something simple like that.
 
Jun 23, 2019
17
1
15
0
If you can borrow (or get for cheap) a DisplayPort to HDMI adapter, give that a shot.

The only reason I say this is because my brother's video card started giving him issues, and switching from the HDMI out to one of the DisplayPort outputs solved the problem for him.

Similarly, I've read a few posts here and there where it seems that one of the output ports on someone's video card had gone bad, but the other ports were fine.

It's a long shot, but it might be something simple like that.
I will try that, thanks. Also when I tried to install AMD drivers for the GPU, it says it doesn't detect the RX 580
 

ASK THE COMMUNITY

TRENDING THREADS