Question Using different PSU cables

Oct 6, 2020
24
0
10
0
Hi all, I’ve got a 550w fully modular Corsair power supply. My fans however even though the case is new, came with fans requiring a 4 pin molex connection. I bought a cheap 6pin to molex off of eBay as the PSU didn’t come with one, is this safe and if not whats the chances of something bad happening and if so what’s the worst case?
 
General recommendation is to use only original cables for modular PSUs. Wrong cables can kill any device connected.

Please provide photo of the adapter being used.

If you're connecting just fans to the adapter, then fans will either work or not work.
But if you try to connect HDD or SSD to it, it may kill the drive.
 
Oct 6, 2020
24
0
10
0
The psu didn’t come with a molex cable which is annoying, also sorry I don’t know how to upload pics onto this 😂 I’m not stupid with tech but seriously we can’t just upload an image straight to this thread? If it’s just fans they should be fine right. If the fans break or whatever I’ll get new ones (WITHOUT STUPID MOLEX) this can’t harm any other parts of my system right?
 
Oct 6, 2020
24
0
10
0
The psu didn’t come with a molex cable which is annoying, also sorry I don’t know how to upload pics onto this 😂 I’m not stupid with tech but seriously we can’t just upload an image straight to this thread? If it’s just fans they should be fine right. If the fans break or whatever I’ll get new ones (WITHOUT STUPID MOLEX) this can’t harm any other parts of my system right?

Upload to imgur.com and post link.

You can as well find image of your adapter on web and post link ot it.
View: https://imgur.com/gallery/q9ZIyz8
 
Oct 6, 2020
24
0
10
0
Hi all thanks for the help, I should’ve waited for a response or read it before rushing into this.... I’ve learnt my lesson... i have paperclip tested my psu and nothing happened... guess I’ll buy a new one hopefully no other parts are damaged
 
Oct 6, 2020
24
0
10
0
Hi all, I supposedly broke my power supply last night (yes I did the paperclip test and no response, startup or fan spinning (after attaching something to give it a load aswell) I know that power supplies can be repaired and as this is worth $160 AUD I don't want to have to buy a new one. Does anyone know what the problem with it could be. I plugged in a pcie 6pin connector to molex 4 pin into it. Just hoping I don't need a new one. Thanks all
 
Hi all, I supposedly broke my power supply last night (yes I did the paperclip test and no response, startup or fan spinning (after attaching something to give it a load aswell) I know that power supplies can be repaired and as this is worth $160 AUD I don't want to have to buy a new one. Does anyone know what the problem with it could be. I plugged in a pcie 6pin connector to molex 4 pin into it. Just hoping I don't need a new one. Thanks all
If it's an RM650x, it's still under warranty.

How is it "broken"?

Please provide all details.

What is the "PCIe 6-pin to Molex you're speaking of and what does it have to do with the PSU "breaking"?
 
Reactions: thefxgamingrules
Oct 6, 2020
24
0
10
0
If it's an RM650x, it's still under warranty.

How is it "broken"?

Please provide all details.

What is the "PCIe 6-pin to Molex you're speaking of and what does it have to do with the PSU "breaking"?
https://forums.tomshardware.com/threads/using-different-psu-cables.3654974/#post-22019027
Click on this link that goes to my other thread about the molex to 6 pin.
its not an rm650x its a rm550x.
I did a paperclip test and stuff but its not working at all even with a connected load. Im not sure if its actually broken or not but it doesn't start or turn on at all.
 
Hi all thanks for the help, I should’ve waited for a response or read it before rushing into this.... I’ve learnt my lesson... i have paperclip tested my psu and nothing happened... guess I’ll buy a new one hopefully no other parts are damaged
Using that cable shouldn't have killed any PSU.

Are you sure you're paper clipping the correct two pins?

Also, the RMx has a zero RPM fan. So you can't count on the fan to spin if you do paper clip the correct two pins. Since you don't have the proper Molex cables (which are pretty readily available), you could just use a multi-meter to see if you're getting voltages on any of the other pins.
 
Oct 6, 2020
24
0
10
0
Well, that's just it. Right? A wrong cable is going to keep it from working. :D

Take JUST THE PSU. And JUST THE 24-pin cable. No other cables not hooked up to anything else.
Yeah the power supply is all good. I’m starting to think it’s the motherboard now, not sure how I can tell exactly how it’s dead but there’s no sign of it turning on
 

ASK THE COMMUNITY