Question V-Sync

Jun 8, 2019
28
1
35
0
I have been getting input lag in all of my games in the past year and I figured it couldn't have been because of V-sync because I was getting more fps than my monitors refresh rate. Is there a chance it is still on even though I am achieving a higher fps than my monitors refresh rate?
 
What are the specs of this system? Are you using something like an SLI setup? Have you tried enabling/disabling different sync settings in your Nvidia control panel, like Fastsync, G-Sync Compatible, or triple-buffering?

And how are you detecting this input latency? Could it just be network latency or something?
 
Jun 8, 2019
28
1
35
0
What are the specs of this system? Are you using something like an SLI setup? Have you tried enabling/disabling different sync settings in your Nvidia control panel, like Fastsync, G-Sync Compatible, or triple-buffering?

And how are you detecting this input latency? Could it just be network latency or something?
I cant find gsync in the nvidia control panel or fastsync, triple buffering is off and network isnt the issue because it happens in local LAN servers

2080ti
i9-9900k
32gb ddr4 ram
 
Fast Sync is just an alternate v-sync method, and you would select "fast" under the v-sync setting, rather than on or off. It's to improve the performance of v-sync though, and if you have v-sync disabled, then it's not going to improve latency over what you already have...


I believe your monitor may support FreeSync, so the option to enable G-Sync would only appear if you have FreeSync enabled in your monitor's settings, have your monitor connected using a DisplayPort cable, then an option should appear to activate it for the screen from within Nvidia's control panel. However, again, it's main purpose is to be a better-performing form of v-sync, and it's unlikely to improve performance over having that turned off, just eliminate screen tearing, and only when your frame rate is below your monitor's max refresh rate.

One thing I did notice when doing a quick search about that mouse is that a review mentions there being an additional 1-2ms of input latency at DPI settings of 2100 or above. I'm not sure that kind of latency would actually be perceptible, but it might be worth dropping the DPI setting to 2000 and seeing if that makes any difference.

More importantly, you might want to try turning off "improve pointer precision" if it's turned on in the mouse's settings, as that can mess with the accuracy of mouse movement. I think most games should ignore that setting and get raw input anyway though.
 
Jun 8, 2019
28
1
35
0
Fast Sync is just an alternate v-sync method, and you would select "fast" under the v-sync setting, rather than on or off. It's to improve the performance of v-sync though, and if you have v-sync disabled, then it's not going to improve latency over what you already have...


I believe your monitor may support FreeSync, so the option to enable G-Sync would only appear if you have FreeSync enabled in your monitor's settings, have your monitor connected using a DisplayPort cable, then an option should appear to activate it for the screen from within Nvidia's control panel. However, again, it's main purpose is to be a better-performing form of v-sync, and it's unlikely to improve performance over having that turned off, just eliminate screen tearing, and only when your frame rate is below your monitor's max refresh rate.

One thing I did notice when doing a quick search about that mouse is that a review mentions there being an additional 1-2ms of input latency at DPI settings of 2100 or above. I'm not sure that kind of latency would actually be perceptible, but it might be worth dropping the DPI setting to 2000 and seeing if that makes any difference.

More importantly, you might want to try turning off "improve pointer precision" if it's turned on in the mouse's settings, as that can mess with the accuracy of mouse movement. I think most games should ignore that setting and get raw input anyway though.
Thank you, pointer precision was already off. My mouses dpi is at 800 so that can’t be the issue. I just reset my bios and for some reason that did the trick. Have no clue why
 

ASK THE COMMUNITY

TRENDING THREADS