Question Vega 56 Bricked after Broken Bios Switch

NateCordova

Distinguished
Sep 25, 2012
10
0
18,510
0
Before Posting: Please do not post "You should have known" type of comments

Hello all,

My dear Sapphire Pulse Vega 56 does not output any signal after Breaking its Bios Switch Button.

Was attempting to switch to a different bios to flash a Vega 64 Bios, but when I tried to switch the bios, the switch broke.
At first it just broke the plastic tip, but the card still worked (just unable to switch bioses). Attempting to switch bios with a screwdriver, I may have forced it a bit too much, and the whole button came apart.

Now, the card doesn't output any signal, even though the fans still spin (they should stop spinning though) and the rgb is on.

There are two scenarios that I suspect:
A) the button broke and broke something with it (like the firmware can't figure out what bios it is)
B) I don't remember fully if I've tried to flash a V64 bios on that second Bios slot and failed (hence the no output). Maybe I actually managed to switch the bios and it's stuck on a non working bios.

My cpu does not have integrated graphics to test this and i don't really have access to a system with one (I mean , I do, but it's power supply is only 8+6 pins).

Can anyone give me some useful information on how to fix this?



 

AMDynamic

Reputable
Apr 23, 2016
75
2
4,545
1
Either something went wrong if you managed to flash it in that case it's either on board graphics to find fix or you might have nudged something when the screw driver flipped it over causing some damage.

I hope you get a fix for it somewhere otherwise you might have to eBay it off if nothing is found.
 

ASK THE COMMUNITY