[SOLVED] Vega 64 Memory Frequency Stuck!

davew1860

Proper
Feb 6, 2019
143
29
120
2
Whenever I run the Heaven Benchmark or play Battlefield V, for instance, my memory frequency sticks at 500MHz or 800MHz.

As you can see in my AMD WattMan settings below, I want the memory frequency to be at 1075MHz.

Why is it downclocking? My temperatures are all under 75°C.

GPU states 1-7 MHz, respectively: 977, 1067, 1122, 1182, 1382, 1512, 1607
GPU states 1-7 mV, respectively: 800, 835, 870, 905, 940, 975, 1025
Power limit: 50%
Memory state 3 MHz: 1075
Memory state 3 mV: 975

CPU: AMD Ryzen 7 1700X
Motherboard: ASUS ROG Strix B450-F Gaming
Video card: SAPPHIRE Radeon RX Vega 64 8GB (with 19.4.1 driver version)
RAM: G.SKILL TridentZ RGB Series 16GB
SSD's: SanDisk Ultra 3D SSD 512GB / Samsung SSD 860 EVO 250GB
HDD's: Western Digital Black 7200 RPM 1TB / Seagate BarraCuda 7200 RPM 250GB
PSU: CORSAIR RM850x White 850W
 

Metal Messiah.

Commendable
Mar 28, 2019
2,204
454
1,790
61
Have you tried to do a CLEAN re-install of the AMD Radeon drivers, including Wattman ? Use the DDU tool to do a re-install. Remove all previous saved profile, and other settings for the AMD software. Restore everything back to default value.

https://www.guru3d.com/files-details/display-driver-uninstaller-download.html

When did this problem start to occur ? Try to ROLLBACK the GPU drivers, if need be.
 
Reactions: davew1860

davew1860

Proper
Feb 6, 2019
143
29
120
2
You'd be lucky to get 1075 in a Vega 64 overclock.
You should pretty much leave that at default and OC the Base clock - not that you gain much more than 5% from an OC with these cards.
The card is actually stable at 1075MHz, so I did luck out on the memory frequency.

However, I actually downclocked the core frequencies by 1.5%. Otherwise, spikes in these frequencies would cause crashes in games.

After applying all of my revised settings below - including increasing my fan curve - I experience a 10% increase in average FPS for Battlefield V, without any crashes. My resolution is 1080p, and I use ultra settings.

My revised WattMan settings are as follows:

GPU states 1-7 MHz, respectively: 977, 1067, 1122, 1182, 1382, 1512, 1607
GPU states 1-7 mV, respectively: 800, 840, 880, 920, 960, 1000, 1050
Power limit: 50%
Memory state 3 MHz: 1075 (it actually works now!)
Memory state 3 mV: 975
 
Reactions: ElectrO_90

davew1860

Proper
Feb 6, 2019
143
29
120
2
Have you tried to do a CLEAN re-install of the AMD Radeon drivers, including Wattman ? Use the DDU tool to do a re-install. Remove all previous saved profile, and other settings for the AMD software. Restore everything back to default value.

https://www.guru3d.com/files-details/display-driver-uninstaller-download.html

When did this problem start to occur ? Try to ROLLBACK the GPU drivers, if need be.
I DID do this. First, I did it OUT of safe mode, which did nothing for me. Second, I did it IN safe mode, which may have helped me. In safe mode, the reinstallation appeared to make additional changes.

I am now hitting a stable 1075MHz memory frequency! However, before achieving this, I did make adjustments to my GPU voltages, which I show above. I increased them.

Hence, I don't know what solved my problem - reinstalling the driver in safe mode or increasing my GPU voltages or perhaps both. What do you think?

At any rate, thanks!
 
Reactions: Metal Messiah.

ASK THE COMMUNITY

TRENDING THREADS