Vertex 2 Freezes in Windows 7 64 Bit


Jan 20, 2010
Hi all,

New time user for SSDs here--got the Vertex 2 3.5" 360 Gig SSD for Christmas. My problem that I'm having is that my Vertex 2 works perfectly fine, running smooth and fast through Windows 7 x64 install, but then freezes several hours later (managed to update all Windows file through Windows Update, then tried adding AVG antivirus which is where it froze). The mouse pointer still works, and icons seem to respond, but when I click to do anything, nothing happens. Soon after the system resets itself. On reset, not even BIOS sees the Vertex 2 drive as existing. Only on a hard shutdown will BIOS see the SSD again, but now the drive doesn't last more than a few minutes before freezing. I'm RMAing the drive, but when I get the replacement, I'll be stuck with the same problem if it's a compatibility issue. So I've come to ask for advice, whether it be big or small.

Windows 7 properly recognizes the SSD; defrag is turned off, and the SSD is not on the defrag list.

Things I've tried:
-Updated the BIOS to the most recent version (Mobo is P6X58D Premium)
-Tried updating the firmware of the SSD, but OCZ's 'SSD Update' doesn't show the drive--I refresh the drive list and it comes back as No Drives Found)
-Reinstalled Windows 7 using AHCI, results in same freezing
-Tried increasing the voltage to PCI-E
-Physically moved the SSD to a different SATA slot. (kept my 1 HDD unplugged, so the SSD is the only thing attached)
-Tried updating the mobo chipset, and now my computer won't restart, so I now have to reset the mobo before I can continue troubleshooting. No idea what happened there.

If it is a compatibility issue, is there anything I can change in BIOS that might help? I don't overclock and most things are set to auto.

My computer specs:

Mobo: Asus P6X58D Premium
Processor: Intel i7 950
Video: Radeon Sapphire 5970
Memory: Patriot Viper (3x2 Gig)
850 Watt power
Also attached is an LG Blue Ray player, and Western Digital 1TB HDD

Any help would be appreciated.
Recommend you down load the latest Intel RST drivers (Ver 9.6 or later), also down load the "F6" ahci driver. Back to the older days. Do a custom instal, on the page asking where to install win 7 (Also allows you to partition the drive) there is a check box for required drivers, check it then broose to the USB thumb drive that you put the "F6" files on. Not positive that this will work, but the SSDs with the SF1200 controllers work best with the latest INTEL AHCI driver. Installation will instal the MS ahci driver by default if you do not specify.

Would run memtest from a bootable disk, just to reverify that you do not have any memory problems BEFORE you install operating system.

Also verify that your PSU is not starting to fade out on you - you specified wattage, but not brand.


I have very very similar issue with the 3.5 vertex 2 120 gb. It used to work without problems for 2 months, then the problem started and now I can't use a computer for more than few minutes before it freezes. when it freezes the HDD LED is permanently ON. Reset does not work, it doesnt come past bios screen. I have to turn the pc off and on.

I'll run memtest and try changing sata cables, but the weird thing is that it worked without problems for 2 months.

also win7 x64. MSI P55-GD65 board


May 3, 2011
Any luck solving the problem?
I am having the same problem on an Asus P6T deluxe V2. It will work 5-120 minutes, then freezes and resets without recognizing the drive...

Were you able to find a solution?
Thank you!


Feb 20, 2010
many confuse "bad drive" with incompatible drive". The drives don't "die".. they panic lock and are inaccessible until destructive flashed via RMA.

Sandforce has known sleep issues and it would be highly advised to flash the latest firmware since so many fixes were finally made available to vendors of their chips. Even then though, some are still seeing sleep transition issues that can manifest into corrupted and locked drives(yes.. weeks and months down the line) and it's still best to not sleep the drives until Sandforce gets more work done to ease the panic locks.


May 17, 2010
Same thing happened to me 3.5" 120gb Vertex 2.
I have had it for over 6 months, after I boot win 7 x64 it freezes after 2-20 minutes... don't know whats going on here.


Feb 20, 2010

not to take anything away from the abilities of the forum members here.. but I would always first try the mfgrs forum to troubleshoot the issue.

About the only thing you could do to recover from those issues would be to

save any important data right away
reset the boards cmos and make sure you are in AHCI mode
secure erase(SE) the SSD(with the toolbox or Linux tool from the mfgr)
flash the latest firmware for the drive(1.35) with the same tool mentioned above
reinstall a fresh OS

most likely an issue from faulty mapping of data at the controllers level and SE/fresh install should get you back on track.

if the problem persists?.. get the drive replaced under RMA. Good luck with it