Question Very high memory usage when idle

Jamppandeerus

Prominent
Aug 12, 2019
22
1
515
0
So, as i am writing this, my memory usage is 77% in task manager when i have 3 tabs of chrome open, steam and discord, I should have 12GB of DDR3, but my pc is using 9.2GB right now according to the task manager, and in the users tab, my ram usage should only be 1770MB so that does not add up at all, I did a virus scan, found 2 threats and deleted them. But my ram usage is still high, usually the usage becomes high when i have played something and i have shut down the game, but the game is shut down, so it should not be causing any problems, and I am not seeing the game in task manager so it should be shut down, any help would be appreciated, cause I would prefer not to factory reset my PC because of this stupid problem
 

Lutfij

Titan
Moderator
When you speak of idle, it means that you don't have any app;s open apart from the apps that run in the background. It's also known from some forums, that certain pages tax a system differently regardless of how many tabs are opened up.

Also, we're going to need a lot more information, given that this is a troubleshooting thread. List your specs and also include your version for Windows 10(assuming you're on Windows 10).

Check and see which BIOS version your motherboard is on, currently.
 

Jamppandeerus

Prominent
Aug 12, 2019
22
1
515
0
When you speak of idle, it means that you don't have any app;s open apart from the apps that run in the background. It's also known from some forums, that certain pages tax a system differently regardless of how many tabs are opened up.

Also, we're going to need a lot more information, given that this is a troubleshooting thread. List your specs and also include your version for Windows 10(assuming you're on Windows 10).

Check and see which BIOS version your motherboard is on, currently.
Yes, My CPU is an I5-3350p, my GPU, Asus Strix RX 570 4GB, and a motherboard I don't know the name of, my PC was originally a 2012 Asus prebuilt and I changed the gpu, psu and cpu cooler, and added 4GB more ddr3 ram, and my bios is american megatrends some 2012 version, command prompt says the version is 0507, and my windows 10 version is 1903
 

ASK THE COMMUNITY

TRENDING THREADS