Question very peculiar problem-HDD fails but works when i switch sata port. and then again fails, and again works after switch

Dec 4, 2019
2
0
10
0
so this has been going for like a year.
I get BSOD or just freeze. and then chkdsk starts getting errors all over the placve, in particular bitmap volume, or security descriptors, and is also unable to fix due to to not enough disk space. which is funny with 126gb free on a 300gb.
but when i switch it to a different sata bus. everything works, i do chekc disk- and walla, no problems, like magic.
also, when i try to connect 4 devices to the sata bus, it doesn't recognize one of them. like for now i had to put the cd out of the equation.
after a while it gets back to the same problems. i tried /b /r /f with chkdsk to repair, and it does repair some, but the big "table mft" cant be repaired.
until it simply wont boot the windows(7). i switch ports and here we go again.

so i'm guessing its the motherboard. but its an old socket 1150lba. generation4 of intel i7.

which is now hard to come by.

any suggestions?
the situation now is after switch ports, so no errors occurred after chkdsk.
I'm using windows 7 on i7 4790k. 16gb ram. and 3X1T HDD's.
my mobo is gigabyte GA-H97M-D3H.

p.s.
I cleaned my computer with spray that should be ok to use on cleaning insides of computers. but could be it screwed up my sata ports?
or perhaps more cleaning with spray could help?
 
Dec 4, 2019
2
0
10
0
yes. i've tried different cables. and then returned to the old one.
because just the port switching seems to work.

i used compressed air spray, the kind that you use to clean the insides of a computer from dust.
 

ASK THE COMMUNITY

TRENDING THREADS