Question very slower than advertised SSD , tried most of things you may think about

May 9, 2019
Hello all
i have X79 UD3 Gigabyte board , with i7 3930K , 16GB of 1600MHZ ram and Thermaltake SE 730W PSU , on windows 10 (1903)

bought Liteon MU2 SSD (Rated with over 500 MB Read and write speed) and someone who purchased it from same place gave me it's benchmarks and it was functioning as advertised..

but when i connected it , i found Read speeds doesn't go over 380 and write speed doesn't go over 100 .. which is very very very below advertised ..

System is on ACHI , Controller is on Sata 3 Intel controllers (also tried marvel , same) , tried millions of AHCI drivers , Tried reinstall windows , no luck .. Power to high performance .. Enabled write cache .. no luck
but i noticed something .. with Atto i get the speeds that are advertised ... and in Crystal mark when i make test data to 0 Fill it gets the advertised speeds .. the other people with same ssd don't have to do that to get their speeds .. so what exactly is going on?
Last edited: