Question Very strange probelm with Logitech G633

garrusvakarian

Prominent
Feb 19, 2018
15
0
510
0
Today I bought a Logitech G633 Artermus Spectrum Headset.
After I tested it in my cellphone and pc I decided to install the software for the Logitech G products.

After the installation I tried to activate the surround settings in the software and started the 7.1 test, I canceld it.
After that the sound in the right speaker dissapeared, even if I close down the software or use the 3,5 mm aux in the pc or cellphone there is still no sound in the right speaker of the headset.
I have uninstalled the drivers in the device manager and restart the computer, but the problem is still there.
Also if I start a surround test in the G software it inst any sound at all in the headset but if I listen to youtube, cellphone and others there is still sound but only in the left speaker.

Anyone here knows what is wrong?

Edit: Now the surround test work in leftspeaker, everysound is in the left speaker. So when the software says this is the right channel I hear it in the left.
 

Fix_that_Glitch

Notable
Mar 31, 2019
1,423
112
940
32
Try this.
  1. Install the latest version of Logitech Gaming Software.
  2. Go to Control Panel > Device Manager > Sound, Video, and Game Controllers
  3. Right click your Logitech Device
  4. With the right-click options showing, unplug your USB headset.
  5. Click uninstall device (if there are options to uninstall the driver as well make sure to check the option on before uninstall).
  6. Plug your USB headset back into the USB socket.
  7. Test the surround sound option in Logitech Gaming Software
 

ASK THE COMMUNITY

TRENDING THREADS