Question VGA Light On Motherboard (White)

Dec 5, 2019
3
0
10
0
Newly built computer

CPU: Ryzen 3800
Motherboard: TUF Gaming X570 - Plus Wifi
GPU: Gigabyte Radeon 5700 XT
PSU: Corsair TX750M 80+ Gold

Used for accumulation of about 7 hours more or less

Randomly lose my display and the VGA light shines white on the motherboard.
Tried Different HDMI Cords
Tried Different Monitor
Tried reseating GPU in diff slots
Tried old GPU in current MOBO
Exchanged MOBO at store
Reseated Ram
Tried old PSU
Tried NO GPU and HDMI into MOBO

Please help, I've tried all these and the same white light stays on and I cannot get a display, nor can I get into BIOS
 
Last edited:

Lutfij

Titan
Moderator
By old PSU, what is the make and model of the unit and how old is it? You won't get any display out of that platform with an AMD Ryzen 3800 since it does not have an iGPU on that CPU's die. If you had an APU, on the other hand then you'd have gotten display output from the motherboard.

That being said, did you take the GPU to a donor system to rule out a bad GPU? You will need to also source/borrow a reliably built PSU akin to the Corsair unit you have to rule out a faulty PSU.
 
Dec 5, 2019
3
0
10
0
PSU IS 750 80+ bronze
It’s about 11 years old.

The PSU was still being used for the rig I JUST got rid of that was powering an i7 2600 with a RTX 970

I deducted that it wasn’t bad GPU, because when I put my old RTX 970 in the 570X MOBO, the same problem still occurred

and to be more specific, when I randomly lost display and the VGA light came on;
I was in the middle of watching a video on YouTube and having an SSD formatted. (The SSD had my old windows 7 OS on it)
My current OS is Win 10 Pro
 

ASK THE COMMUNITY

TRENDING THREADS