Question Video image quality HDMI to TV

Dec 21, 2020
8
0
10
0
Hi there!

I have some issues with video quality. Specifically, when I watch videos by connecting my HP desktop (NVIDIA RTX 2070 Super) to my LG 4K TV through HDMI, I see pixelation/blurry 'rings', especially in dark areas of the video. When I watch that exact same video through for example the YouTube Smart TV App, it looks fine. Same when I watch other videos through HDMI vs streaming / TV apps.

Now I don't know if this is because there is a problem with my desktop/GPU, or some compression issues that arise by connecting the desktop to a TV as monitor through HDMI. Nevertheless: I would think that such a powerful GPU would be able to play any videos at optimal quality, but maybe I am wrong to expect that.

Any insights is much appreciated as for the life of me I cannot figure this one out!

Thanks

FYI: I have added screenshots of the problem and side by side comparison, below the arrows here https://ibb.co/k9p4FYt). The video here is Alex Rider trailer on YouTube between 40-50 sec (but same issue applies to other videos)
 

DrummerManSpike

Notable
Jan 9, 2020
283
59
940
70
What kind of HDMI cable do you have? They're constantly evolving much like USB is. For 4k resolution data streaming, make sure you have a High Speed HDMI 2.1 cable. It could be that your current HDMI cable is not rated for that kind of quality.
 

jojesa

Illustrious
Hi there!

I have some issues with video quality. Specifically, when I watch videos by connecting my HP desktop (NVIDIA RTX 2070 Super) to my LG 4K TV through HDMI, I see pixelation/blurry 'rings', especially in dark areas of the video. When I watch that exact same video through for example the YouTube Smart TV App, it looks fine. Same when I watch other videos through HDMI vs streaming / TV apps.

Now I don't know if this is because there is a problem with my desktop/GPU, or some compression issues that arise by connecting the desktop to a TV as monitor through HDMI. Nevertheless: I would think that such a powerful GPU would be able to play any videos at optimal quality, but maybe I am wrong to expect that.

Any insights is much appreciated as for the life of me I cannot figure this one out!

Thanks

FYI: I have added screenshots of the problem and side by side comparison, below the arrows here https://ibb.co/k9p4FYt). The video here is Alex Rider trailer on YouTube between 40-50 sec (but same issue applies to other videos)
Which video player are you using?
When you are playing the video and it shows pixilation, does it get better if you jump back a few seconds?
Try VLC media player and see if it helps.
 
Dec 21, 2020
8
0
10
0
Thanks! These issues arise with all video players, albeit in varying degrees. From most to least pixelation: any videos via browser, VLC, Netflix desktop app.

The only thing I can think of, is that I am using a 65 inch TV as my monitor, and the compression of all these video players does not account for that and that is why I see pixelation/ artifacts. But then again, I would think (and hope) that the powerful GPU would at least play the videos through VLC or Netflix app well enough, even on a bigger screen.
 
Dec 21, 2020
8
0
10
0
Thanks. But I mostly experience this issue with 1080p videos - not exclusively.

And more importantly: the exact same 1080p videos look fine when I watch through the Smart TV apps (see screenshot comparison in my first post)
 
Dec 21, 2020
8
0
10
0
Thats the point, a 1080p video the TV has to upscale to 4K otherwise it would only use a 1/4 of the 4K screen.
Thanks sizzling - appreciate your input and I see your point regarding upscaling 1080p videos. But 4K videos through eg Netflix app or YouTube would then not show the pixelation right? And they do as well
 

jojesa

Illustrious
I have a LG OLED TV and I have noticed that depending of the content source, most often than not, it is able to upscale correctly and to my liking. It does that on the fly without user input.

As far as I understand the TV (processor) analyses the signal to determine the type and resolution (Cable TV, streaming, HD or full HD, etc...) . The TV processor comes up to the best formula (textures, details, noise reduction, sharpness) to convert the 1080p signal to 4K.
So one has to imaging the processing power and also guess work required to fill a screen from a source delivering just one forth.
 
Dec 21, 2020
8
0
10
0
Thanks! That makes sense. What I am still a bit puzzled by, is:

  • How come the Smart TV apps are able to play exact same videos (1080P and other) without the same pixelation
  • Why 4K videos played via HDMI and e.g. VLC still show (minor) pixelation - and if I stream exact same videos through Plex or something to my TV, the pixelation is not there
That makes me wonder: am I wrong to expect same quality from a HDMI connection with a powergul GPU as that of Smart TV apps (YouTube, Plex, Netflix, etc)?
 

jojesa

Illustrious
Thanks! That makes sense. What I am still a bit puzzled by, is:

  • How come the Smart TV apps are able to play exact same videos (1080P and other) without the same pixelation
  • Why 4K videos played via HDMI and e.g. VLC still show (minor) pixelation - and if I stream exact same videos through Plex or something to my TV, the pixelation is not there
The processing is less strenuous when played from TV apps than when going thru HDMI.

That makes me wonder: am I wrong to expect same quality from a HDMI connection with a powergul GPU as that of Smart TV apps (YouTube, Plex, Netflix, etc)?
It does not have anything to with how powerful a GPU can be, but you could try changing hardware acceleration on and off and see which works best.
The quality of the HDMI cable and the app use to play could play a part on the quality of the content.
I don't think you're wrong about expecting the same quality. I do too.


To disable hardware acceleration in VLC
Open VLC Media Player.
Go to Tools and select Preferences.
Select Input / Codecs
Toggle between the choices or disable it altogether.

On VLC you could play with a lot of settings
Try increasing the cache
Open VLC Media Player.
Go to Tools and select Preferences.
At the bottom of the screen, click All to reveal all options.
On the left pane, scroll to Stream Output.
On the right pane, change Stream output muxer caching (ms) to 2000 milliseconds.

Also you could change the output module.
Open VLC Media Player.
Go to Tools and select Preferences.
At the bottom of the screen, click All to reveal all options.
On the left pane, scroll to Video> Output Modules.
On the right pane, switch the Video Output Modules to either Direct3d11 or Open GL or DirectX.
 

ASK THE COMMUNITY

TRENDING THREADS