Question Video output lost after installing Intel drivers on new PC ?

Dec 18, 2022
Trying to put together a PC for my cousin who's going off to college in a few months and I'm at a loss for what's going on.
Asus z690-A prime, DDR5 - bios is updated to latest version, default settings
2x16 GB corsair dominator
2tb Platinum hynix m.2
Thermaltake toughpower gf1 snow 850w
No GPU yet - his parents are buying this for him and it hasn't arrived yet

Problem: Whenever the computer connects to the internet, the monitor turns black but does not show "No signal".
No cursor. Windows + Shift + CTRL + B does nothing.
I put all the components together, updated the bios, did a fresh install of windows 10. Loaded into windows fine, did all the configuration steps. Loaded to desktop and installed LAN drivers for internet. About a minute after LAN drivers are installed and the PC connects to the internet, the screen goes black.

Rebooting lets me get back into bios but past bios is just the same black screen. The monitor seems like its receiving input since it doesn't give me a "no signal" message, but its just black. Tried switching monitors, tried switching motherboard ports, same thing.

Changed boot order in bios and reinstalled windows but this time didn't install any LAN drivers - no display problem but the computer is stuck on Microsoft Basic Display Adapter.

Installed CPU-z onto a flash drive - CPU works fine under full load, bench is about average for a 13600k. memcheck passed. Tried plugging in a 6900 from my current PC. No display from any of the 6900 ports. So I don't think it's the CPU, ram or PSU.

Manually downloaded recommended motherboard drivers on a different PC, put them on a USB and tried to install them on the problem PC. All the drivers installed fine until I got to the Intel DCH drivers for the Intel UHD iGPU. Tested it a few times and it looks like every time the PC tries to install display drivers, the screen goes black and the mobo stops outputting video. It'll start installing the intel UHD drivers and after a minute or two as it's installing the screen goes black.

Tried to manually install AMD adrealin drivers seeing if I could just use a dedicated GPU to get around the intel onboard problem. After restart AMD refuses to open and says windows update is overwriting AMD drivers (even though the PC isn't connected to the internet, so I'm not sure where it's getting drivers from). 6900 ports don't work - monitors show as "no input" vs just black when connected to the motherboard.

Reinstalled windows then restarted in safe mode and tried installing drivers again. Intel DCH drivers successfully installed and showed under device manager as Intel UHD. Restarted and tried to boot into windows normally - black screen again.

So it looks like the computer only outputs video with Microsoft basic display adapter and there's something interfering with display drivers when the PC is booted into windows normally.

Any ideas? I've got like two days left to order more parts if I want everything ready by Christmas. Was thinking it might be the motherboard.