Video settings on Gigabyte AMD785 board

SystemPat

Distinguished
Sep 9, 2009
69
0
18,640
3
I can't find the correct setting for my widescreen monitor. It's a 22" LCD display and the native resolution is 1680 x 1050. That is not one of the choices in the setting or the ATI control panels. In fact there are very few widescreen resolutions. I tried to upload the Video drivers from Gigabyte. Not sure if I was successful as nothing seemed to change. Motherboard model is GA-MA785GM-us2h.
Any help would be greatly appreciated. I originally had it plugged in as VGA and let it run as 1280x1024. When I connected it as DVI to the correct monitor I thought it would give the correct options. But it did not.
 

godless

Distinguished
Dec 27, 2007
624
0
18,990
3
i have the same board an no issues on one of my builds. which os are you running. xp works perfectly for me on that resolution on 22" samsung. i did have some problems with the windows 7. i am also plugged in with the VGA
 

SystemPat

Distinguished
Sep 9, 2009
69
0
18,640
3
Thanks for the replies. I am running it on WinXP. It originally was running from the drivers on the CD. Not sure what driver it's on now. I tried to download from Gigabyte. Think I'll try the AMD link from bilbat.
 

SystemPat

Distinguished
Sep 9, 2009
69
0
18,640
3
I have installed from the AMD link for the 9.8 drivers. There was some kind of conflict in versions for the Control Center ( CCC ) So I uninstalled the drivers and the CCC and then installed the the new ones. It still does not show all possible modes. It seems to have identified my Sceptre monitor as having a native resolution of 1920x1080. But it does not. It should be 1680x1050. Seems to be no way I can find to tell it to just use that resolution. Frustration level is growing. :fou:
 

bilbat

Splendid
Forcing Desktop Property Settings Using Desktop Properties
If needed, you can force ATI Catalyst™ Control Center to override desktop property settings that are required, or not allowed, by a specific application.
1.From the Graphics menu, click Desktops & Displays. Alternatively, click the Home button in the ATI Catalyst Control Center banner.
2.Click the triangular icon on the desired desktop surface. In the context menu that appears, click Properties. The Desktop Properties page appears.
3.Click the Mode tab, and then click Force. A menu listing all desktop property settings and their associated values appear.
4.In the menu, select the appropriate value for the desired display setting.
5.Click Apply.
The selected setting is applied to your display
 

SystemPat

Distinguished
Sep 9, 2009
69
0
18,640
3
Really appreciate your effort on finding the settings. However, when I go to the Catalyst Center (CCC), I don't find any home button or triangular icon. Maybe it has changed? When I do get to where the Force button there is no 'mode' tab or button. And when I expand using the Force button and go to the list for the Desktop areas, it has the same list of display resolutions as I already had. So it still is not working.
By the way my older PC, which is running an AMD690g with an X2 5200, can see the display thru the DVI connector and does the resolution just fine.
 

Mongox

Distinguished
Aug 19, 2009
1,124
0
19,460
58
No one seemed to ask this earlier - is the system showing a PlugnPlay monitor or your correct model? Regardless, I'd try un-installing the current monitor driver, rebooting, then re-installing the driver supplied. If it shows the correct monitor and it loaded "automatically", look for a driver online for that model and manually update it.

BTW, I'm running the same board and don't have the Catalyst Control Center installed. I just direct the system to the drivers and let them install. Everything runs great and no overhead of s/w I have no use for. I do this with many supplied utilities (scanners, printers, etc..) rather than load up memory and startup with various monitors and crud.

So I would go to this page and get only the display driver:
http://game.amd.com/us-en/drivers_catalyst.aspx?p=xp/integratedip-xp
 

bilbat

Splendid
That's a point - I only load CCC as I use it to OC my cards and 'manage' the Avivo codecs; I have found zero problems with the 'as shipped' 7 drivers by themselves, and that includes back during the RCs, when the CCC would 'break' IE8, and cause it to crash anytime you right-clicked on a favorite...

The 'triangle' is here:
 

SystemPat

Distinguished
Sep 9, 2009
69
0
18,640
3
Displays shows as a Plug'n'play in Properties with a Microsoft driver from 2001. Remember this is XP. I have looked for a driver disk for the Sceptre and don't find one. Can't remember if it came with one or not. Am now looking online to get a driver. The CCC, for better or worse, identifies it as a Sceptre monitor but misidentifies it as native res of 1920x1080. And almost all of the widescreen res that are less than 1080p are not available - like 1680x1050 or 1440x900. Something is preventing these other modes from being options.

The driver file should be a .inf file - is that correct?

Bilbat - the CCC looks a bit different in XP apparently. Once this problem gets solved I may uninstall it as it does nothing fro me most of the time.
 

SystemPat

Distinguished
Sep 9, 2009
69
0
18,640
3


I think I have the current driver - downloaded as part of the package with the CCC. Driver shows as version 8.64 .
 

SystemPat

Distinguished
Sep 9, 2009
69
0
18,640
3
OKay, I was looking around too for this. There are a couple of versions of a sceptre.inf file. Once I have it, followed the instructions to update the driver for the display. After directing it to the .inf file, I select the model. Windows warns that it is not digitally signed - but I go thru the warning. Then restart. When it comes back, the settings are STILL THE SAME. After a bit of ranting, I viewed into the .inf file. There are a variety of entries for the various models and it branches to what must be entries for the Registry.
Are there entries in the Registry that must now be cleared ???
By using something like this?:

;COMMON ADD/DEL REG SECTION
[DEL_CURRENT_REG]
HKR,MODES
HKR,,MAXRESOLUTION
HKR,,DPMS
HKR,,ICMProfile
 

Mongox

Distinguished
Aug 19, 2009
1,124
0
19,460
58
I've never had to edit the Registry to get a monitor driver to show the right modes.

Which model exactly do you have?

I think the key lines are under the model name, such as:
T210
[T210.INSTALL]
DelReg=DCR
AddReg=210.AddReg

[210.AddReg]
HKR,"MODES\1680,1050",MODE1,,"30.5-66.0,55.0-60.0,+,+"
HKR,"MODES\1280,1024",MODE1,,"30.5-83.0,55.0-76.5,+,+"
HKR,"MAXRESOLUTION,,"1680,1050"
HKR,,DPMS,,1

I picked that model at random...

But yes, I see lines like that in my Samsung 2232BW .inf file:
DelReg=DEL_CURRENT_REG
AddReg=SM2232BWa.AddReg, 1680, DPMS
CopyFiles=SM2232BWa.CopyFiles

............

At this point, I'd be tempted to re-write the all-in-one driver file they supply - remove the entries related to other models, make it lean and clean so you can make sure all needed lines are in it. I'm not impressed with that huge file they provide.
 

SystemPat

Distinguished
Sep 9, 2009
69
0
18,640
3
I have seen while googling on the file name sceptre.inf some sign others have had this problem. I have another .inf that has only 4 model entries - for widescreen models. that entry you point to in your message would be correct parameters. But it seems the earlier entry with the 1920 resolution still rules. I'm not a registry guru. I have tried the shorter .inf mentioned above and still not seen the widescreen resolution. Driving me crazy. I'm starting to wonder about the ATI driver. The other PC that works right is on 8.60 driver. May try that.
 

Mongox

Distinguished
Aug 19, 2009
1,124
0
19,460
58
Just for the heck of it, I "updated" my Samsung driver to the Sceptre one and picked the X20WCGamer model, since it used the T210 driver with 1680 mode.
Went into Advanced display, Adaptor modes and got the 1680 mode showing.

So, don't know what else to tell ya. You didn't ever post the model of monitor you're using.



%X20WCGAMER%=T210.INSTALL,MONITOR\SPT2092 ;X20WCGAMER

-------------
Just for the heck of it, might try this. Download the Samsung driver I'm using, install it as a driver update manually. Won't harm your computer at 1024 or such mode. Reboot, chk the modes available, then reinstall the Sceptre one.
http://www.samsung.com/us/support/detail/supportPrdDetail.do
2232BWPLUS
 

SystemPat

Distinguished
Sep 9, 2009
69
0
18,640
3
Model is X22HG-Naga. Found it on special at the Office Max about 9 months ago. The modes for it are the same as for the model you picked. I'm not sure the (monitor) driver even matters. I looked at the other system - the one I'm using here - which worked correctly. And it says Plug'n'play monitor. I get the impression that when it is using the generic monitor, then all the modes are listed. But not on my list.
I just ran a report usng Sisoft Sandra that shows all the supported video modes. The widescreen modes for 1440 & 1680 are not there. So I don't know what's going on.
 

SystemPat

Distinguished
Sep 9, 2009
69
0
18,640
3
I give up at this point. I'll either have to use it at the highest resolution that looks good (1280x960) or swap the monitors around. Something in the setup is being very finicky or is just wrong.
 

Mongox

Distinguished
Aug 19, 2009
1,124
0
19,460
58
I'm giving up too - glad you went first.

I was trying the various modes - LOL - I'm sticking with 1024x768

Maybe with new desk setup after I move, I'll put monitor closer to face, but for now, I prefer bigger text!
 

bilbat

Splendid
I've got a couple of Xp boot partitions that haven't been 're-upped' in a while; everything I need Xp to run works fine on Virtual under 7x64, so I'll try a reinstall with the latest CCC, and see if I can figure out the registry situation... It's early, I had a late night (re-installing 7!), so I may be repeatedly missing it, but is this x86 or x64?
 

SystemPat

Distinguished
Sep 9, 2009
69
0
18,640
3
It's 32-bit XP so that must mean x86. I even tried mongox's ploy with the Samsung drivers. It will not list the widescreen modes as one of the options. I have given up for now. My only hope is either a driver update or maybe a BIOS. But it does not seem like something in the realm of the BIOS. This is not that unusual of a resolution. Most 22" displays have it.
Also not sure that the Sceptre is the most solid monitor. Even with the other PC, the resolution at 1680 is fine on the DVI input. If I switch it to VGA cable the display drops to 1440x900 or maybe 13xx by 768 and then it overscans.
 

Mongox

Distinguished
Aug 19, 2009
1,124
0
19,460
58
There's a choice in Advanced, under Monitor - "Hide the modes this monitor can't display". Try un-checking that. If it works, just remember not to choose those it really can't do!

If that doesn't list modes up to 2048 x 1536, then we're back to the adaptor or its driver as the culprit.
 

SystemPat

Distinguished
Sep 9, 2009
69
0
18,640
3
Yes I've had that checked and unchecked. I see the modes at 1920 and 2048. It's the ones I need that have vanished. Is there a way to post a screen-capture, just so you don't think I'm lost?
 

Mongox

Distinguished
Aug 19, 2009
1,124
0
19,460
58
I think you know what you're doing, but still lost! LOL There is something wrong there and I'm not sure that anything but a full Win re-install will fix it.

To post a pic, click on the full Reply button and then on the tiny pic icon. Or surround pic URL with (img)URL(/img) replacing the () with square brackets []
 

Similar threads