Question Video TDR error freeze and reboot when running certain games

Dec 13, 2019
2
0
10
0
hi! coming to the mecca of pc build troubleshooting with hat in hand, hope someone can help out.

Just built a new machine a couple weeks ago; ryzen 7 2700x, radeon 5700xt. Had a few apparently-random freezes here and there since, was getting a little bit worried. Each time, the whole computer would lock up, no reaction to input, including ctrl+alt+del or pressing the power button. Then the computer would reboot on its own after a few seconds. I used WhoCrashed and found that they had to do with my graphics drivers going unresponsive and timing out, but reinstalling those didn't seem to help (even when AMD helpfully happened to release a driver update and I installed that).

Then, the other day I installed Shadow of the Tomb Raider, and trying to start it up causes the identical behavior every time. It happens the instant the game starts, after it's gone to fullscreen but before any logos or anything get displayed; it's just black. The mouse pointer stops moving, and then a few seconds later the machine reboots.

I tried some other games. The same thing happens if I try to run GR: Breakpoint. But it doesn't happen with a host of indie games, or the few other AAA ones I've had a chance to try. Running Tomb Raider with all the settings at minimum still insta-crashes; running AC:Origins at ultra-high-everything doesn't, just makes the fans spin a bit more. So it doesn't seem to be about graphical load.

Any ideas for next steps? I haven't done anything drastic like reinstalling windows yet, because i'm not really sure which extreme steps might help and which ones would just be wasting my time. (Some page or other suggested 100% uninstalling my graphics drivers and installing them clean, but I have no integrated graphics on the machine--if I did that, would I not be able to run the monitor to reinstall them?) Thanks in advance for your help.

Crash dump info (they're all identical as far as I can tell):

This was probably caused by the following module: atikmpag.sys (0xFFFFF80625010818)
Bugcheck code: 0x116 (0xFFFFBE86645B5010, 0xFFFFF80625010818, 0xFFFFFFFFC0000001, 0x3)
Error: VIDEO_TDR_ERROR
file path: C:\Windows\System32\DriverStore\FileRepository\u0349464.inf_amd64_789f2a8b5b866ccf\B349558\atikmpag.sys
product: AMD driver
company: Advanced Micro Devices, Inc.
description: AMD multi-vendor Miniport Driver
Bug check description: This indicates that an attempt to reset the display driver and recover from a timeout failed.

PC build info:
https://pcpartpicker.com/list/cj2mCL
 
Dec 13, 2019
2
0
10
0
other things i have tried so far:
  • increasing the TDR timeout window as described here
  • downloading DDU and the installer for the latest radeon adrenaline, unplugging the computer from the internet, restarting in safe mode, and running DDU then RA to make extra extra sure that only the exact right drivers are installed
  • update AMD chipset drivers
nothing doing. In fact, immediately after I finished running radeon adrenaline to reinstall the drivers, I got the same crash while viewing my desktop. RA had just closed and absolutely nothing else was open, not even a browser.

probably going to do a full clean install of windows next but have no idea how useful it's likely to be. :(
 

ASK THE COMMUNITY