Question Viewport Glitch in 3D Modelling Applications (GeForce GTX 960M)

May 8, 2019
1
0
10
0
Hello,

My laptop is an ASUS ROG G551JW model with an NVIDIA GeForce GTX 960M Graphics Card. As a designer, I use my laptop to run generative art and procedural modelling software such as INCENDIA NEXT (https://www.incendia.net/) and 3D modelling tools such as TopMod (https://code.google.com/archive/p/topmod).

Recently, in the past couple of months in both of these programs I've noticed that their viewports will not display any input such as zoom in/out or changing parameters in the program such as sliders or pressing buttons. What I then found is that the input was being received but not updating in the viewport, as when I minimised the program and opened it again I noticed it had shown the input I gave it. So for example, in TopMod I can press several buttons to change my baseshape model, but if I have a sphere for example opened and I click on the pyramid baseshape it will stay stuck on the sphere model until I minimise and re-open which will then show the pyramid baseshape I originally clicked on but which was not updating in the viewport.

Before posting here, I have tried resolving it on my own using the following steps:
  • Clean Reset of PC (Running Windows 10 - Set to Remove All Previous Files)
  • Uninstalled graphic card driver and installed earliest version found which was 352.84 using a clean install.
  • When it didn't change anything, I then updated it to the latest version online which was 430.39, also using a clean install.
  • Installed Microsoft DirectX® 9.0c End-User Runtime, .NET Framework Runtime and Microsoft Visual C++ Redistributable for Visual Studio 2015, 2017 and 2019.
  • Installed Java Runtime Environment Version 8 Update 211.
  • Laptop is connected to TV through HDMI cable, so I tried changing screen mode to 'Duplicate' so it shows on both screens and also changed the resolution, both of which didn't make a difference.
A couple of the steps above are probably unrelated to the problem, but I've run out of options and am not sure how to proceed. If you may provide any help or advice in this matter I'd be very grateful. I will attach information about my device in the link below through a screenshot of dxdiag.

https://pasteboard.co/IdP4GaZ.png
 

ASK THE COMMUNITY