• Our team is working to address issues posting quotes or media to the forums. Please bear with us as we get this sorted out.

ViewSonic VX922 monitor - black screen - green power light flashes

Status
Not open for further replies.

conquerz

Distinguished
Aug 23, 2006
85
0
18,630
0
Could someone please tell me what's wrong with my ViewSonic VX922. I've had this monitor for about 1.5 to 2 years. It's been working perfect until couple of weeks ago.

In the morning, the monitor seems to work fine. I can switch it on and off without problems. I can change the resolution and refresh rate. The only thing I can't do is change the input type from Digital to Analogue. If I try to do that using the OSD on the monitor, the screen goes black and the green power light begins to flash. The only way to bring it back to life is by unplugging it for about 10 seconds and then plugging it back. Other than the inability to change the signal from digital to analogue, the monitor seems to work fine if I don't touch it. I can even switch it on and off and it works fine.

Now, after about 6 hours of use, this is when things start to go really annoying. If I switch off the monitor, change resolution and refresh rate, change the input type from Digital to Analogue, the monitor screen goes black and stays black (even the "no signal" doesn't appear on the screen). The green power light begins to flash at a rate of about once a second. I have to unplug it, wait and plug it back to make it work again.

When I do get it to work in these situations (by unplugging and plugging it back), it works fine for hours on end, I can play games like Crysis, Call of Duty, Counter Strike Source with no problems all night long without problems... As long as I don't do any of those things I mentioned that result in the black screen and green flashing power light.

I think the problem only occurs when the screen resolution and/or the refresh rate changes. And that too, after about six hours of use. Maybe it's a temperature problem but when its working it works fine for as long as I leave the display switched on.

This problem is re-occuring. It happens every day.

I've tested the monitor on another PC and it gives me the same problem.
I've checked all the cables, connectors and pins, and they all seem to be fine.
I have Vista, Geforce 7600GT and all drivers for all the hardware are updated.

Edit (feb 2008): I said above that it rook 6 hours for problem to occur. I should have tested more. It only takes a couple of hours and sometimes minutes before this problem starts.

Edit2 (march 2008): My monitor is now dead. I can't even switch it on and get a flashing green light only.

Edit3 (feb 2010):
Well, I contacted viewsonic after the above problem back in 2008 and they sent me a new monitor and picked up the old one. But after 1.5 years again, I have got the same problem with the replaced monitor. They are not going to replace this one because they said warranty period is now over.
Anyway, if you read this current thread, there is lot of info on how you can fix this for a couple of bucks yourself. Thanks to everyone who replied.

Here's something I found that may help for anyone who needs this fixed:

Repair ViewSonic VX924 LCD Monitor Blinking Green power Button

[flash=425,344]http://www.youtube.com/v/ZccykxrtX9g[/flash]
 

g3lf

Distinguished
Jan 26, 2008
2
0
18,510
0
I dont have the answer but I've got the same problem with the blank screen and flashing green light. It starting happening after 12 months then more and more frequently taking longer and longer to get the picture back by unplugging power etc... I got it swapped for a replacement but its just as bad if not worse although the picture comes back a bit quicker after it goes down.

It really seems to struggle switching resolutions, this includes loading Windows :??: Also switching Users on WinXP and now I cant switch back & forth to desktop out of some games without the monitor going blank (I can still hear the game going on without me). All my resolutions are 1280x1024 at 60Hz.

The latest percularity is that after switching users on XP, the monitor goes blank but as soon as open a windows such as IE using my keyboard www shortcut it comes back to life ?!

Using WinXP sp2, ati1950xt.
 

conquerz

Distinguished
Aug 23, 2006
85
0
18,630
0
Yeh, I get all those same problems you've described. Looking to get an RMA very soon. Can't find the time.

Thanks for the info about using IE shortcut on keyboard. I'm gona try that and see if it works. :)
 

g3lf

Distinguished
Jan 26, 2008
2
0
18,510
0
I'm sorry and extremely annoyed to report its getting worse and I'm having to revert to switching it off, oh only 4-5 times a day. Absolutely ridiculous, this replacement was actually ok for a month or so but is now worse than my first one.

Oh and about getting an RMA, they didn't blink about agreeing a replacement as soon as I explained the problem which makes me think its obviously an issue. Lastly, customer service arranges dates to pick up the monitor, but they dont turn up and after I call they say they had none in stock ?! and when the couriers do turn up they're over a week late - which for me meant I kept missing them so took 3 attempts and 3 months.

I'll NEVER get a Viewsonic ever again.
 

conquerz

Distinguished
Aug 23, 2006
85
0
18,630
0
Yeh. It didn't work for me. I've noticed that you don't have to unplug the monitor though. You can just switch it off for a few minutes. It's still very annoying though.

Oh yeh, originally I said that the problem starts after about 6 hours of use, but I should have tested more. It only takes a couple of hours and sometimes minutes before this problem starts!!!

Hope to get an RMA very soon.
 

andythebrave

Distinguished
Feb 2, 2008
5
0
18,510
0


ook the monitor is fine
i worked out whats is happening cod 4 is doing a call to the monitor opf to high a refresh rate thats whats doing it its random it can be cretaed by trying to alt tab out of cod 4 now the fix unplug tft 1 min shut down pc
retart pc u get screen renistall direct x and it stops it happening on other games, it looks like its amemry hole problem in game doing a wierd call to monitor , i ahve this fault to but when i put wifes tft on pc its fine, spoke to viewsonic they do not know cuase yetw aiting to see what they say, as this moniors is not fits for purose if it keeps doing it.


 

Interesting. Unusual cause, but quite a good possibility.
 

conquerz

Distinguished
Aug 23, 2006
85
0
18,630
0


I have to admit that the monitor problem began when I started playing Call of Duty 4, but the problem is not related to COD4 anymore. The monitor blanks out all the time whenever I try to launch an application in full screen... including windows itself when it's even booting up!!!

But I am sooo eager to try this resolution out!!!! I'd be laughing if this works!!! Fingers crossed! lol!
 

conquerz

Distinguished
Aug 23, 2006
85
0
18,630
0

Sorry to say but your method didn't fix the problem.

If this was an application problem, it wouldn't have occured when windows is even booting, before the log on screen.

So it's more of a hardware problem. If you read around the web, this is quite common with viewsonic monitors.

Edit:
Forgot to mentioned, re-installing directX did resolve another issue I was having with an old game that I was desperately trying to play online. So thank you very much for suggesting me to re-install directX, even though it didn't resolve the primary object!
 
G

Guest

Guest
its toast RMA it. I had the same problem then the monitor never turned on.
 

bildo123

Distinguished
Feb 6, 2007
1,599
0
19,810
8
That's kind of scary, almost a year later and then it started up...anyone hear of these problems with Westinghouse monitors, recently bought a 24" L2140NM?
 

Gresham

Distinguished
Aug 29, 2008
1
0
18,510
0
I also have a viewsonic VX922 with the same symptoms. I've been trying to find the thread in the forum where I originally heard this (that's how I ended up here), but I haven't found it again yet so take it with a grain of salt. From what I had read these symptoms are caused by a "bloated" capacitor. The post I had read originally was by an electrician who replaced his capacitor and got his monitor working fine. However, I think for most of us we're out of luck unless you have the electrical knowledge or know someone who does, otherwise it's probably a dangerous endeavor.

Although I can't find the original thread again as of yet, you can at least read about bad capacitors on wikipedia. You'll note that symptomatically our monitors do match up, "resets" to get it to work (plug pulling and putting back in, computer resets), instabilities which progressively worse over time (I know my symptoms got worse and worse until I had to hook up an old CRT).

http://en.wikipedia.org/wiki/Capacitor_plague

 

cpuguy06

Distinguished
Sep 2, 2008
1
0
18,510
0
I have replaced the capacitors on my Viewsonic VX910 LCD. Ordered "good" capacitors from Rubycon, soldered them in and the problem still exists. Nothing else on the board looks bad, the power supply board is dark brown in spots...looks like the heat has discolored the board.
 


Well, I hope you did it when your warranty expired. If not, then you have just voided it.
 

ESA1178

Distinguished
Nov 18, 2008
7
0
18,510
0
Same problm on my VX910. Actually this model is the only one that is exempt from a 3 year warranty. So cracking it open, it is unlikely you are still in warranty.
My issue is that initially the screen flickered. Now nothing on the screen. Power light blinks every 3 secs. When it does, there is a click at the same time.
Replaced 2 capacitors, one seemed bulged and brown on the top. Still have the same issue.
 

Hugh Jass Koda

Distinguished
Nov 20, 2008
10
0
18,510
0
I am also having the exact same issues with my VX922. I've tried all I can come up with including formatting my hard drive and reinstalling Windows XP. I thought it may have been a recent update of either DirectX, nVidia's newest versions of their nForce and or Forceware drivers or possibly installing SP3 that started it all for me. So after formatting, I was careful to install older versions of all the above in an attempt to put the system back to a previous enviornment that I am certain was before the problem first began. I was greatly disappointed to find that even this did not solve the problem. Nor did it improve anything. All the formentioned issues still exist and are still steadily progressing in frequency.

One thing I have to add to the previous postings is, if I put this monitor on my other system, which has the same mother board and video card drivers, same version of DirectX and SP2 installed, all exactly as what is installed on the computer the VX922 is normally connected to, the Vx922 works flawlessly. Just like it did for the first year, year and a half I've had it. Which makes no sense at all to me. How can all these problems exist on one computer but not the other when everything installed on them is the same? If the monitor itself is going on the fritz, why does it work perfectly when connected to the other computer? If the problem is not actually the monitor, but a driver or something on the computer itself causing this, why don't I get any of the issues with any of the other monitors I used during the hours of swaping monitors back and forth? One of my spare monitors I used during all this is also a Veiwsonic which has shown none of the problems no matter what system it's on. If I did a good enough job explaining all that, your probably even more stumped as I am as to what is causing our monitors to act as they are seemingly from out of the blue as they have.

As for the Veiwsonic tech support. I spoke with 2 seperate tech support agents. One told me that this is infact a known issue and, unfortunantly, they have not found the cuase of this yet. She even went a bit deeper than that and told me that this issue was their most common call. But they haven't had any of these call in a long time. I was the first caller she has had with this monitor issue in a long time. She was going to check with her boss on where Veiwsonic is with a solution for this and she was going to call me back at home on Monday to let me know. I never heard from her.

The second tech person I spoke with acted like he had never heard of any of this. He acted as if he had no idea as to what I was explaining to him that our monitors are doing. After several minutes with him he set me up with a RMA which I have yet to do.

Anyway, I just stumbled across this forum and thought I'd throw my two cents in. Hopefully the little I added will help someone come up with a solution to this madness we are unfortunantly dealing with daily with our monitors. Good luck to all us in finding the solution and be sure to post it here if found.

Hugh Jass Koda
 

ESA1178

Distinguished
Nov 18, 2008
7
0
18,510
0
Tried it on another PC. Every time the green blinks, the screen flashes, and there is a dim view of the OS. Almost like the contrast is turned way down. Anyhow, I put it back together and put it away until I find a solution...



Mark
 

Hugh Jass Koda

Distinguished
Nov 20, 2008
10
0
18,510
0
That sounds like it could be the light tubes in that monitor are going out. That is something that happens in every LCD monitor in time. It's the same as any household light bulb, they burn out at some point and need replaced. Of course all the things talked about above are not due to the normal life span of the light tubes.

I installing the newest nVidia Forceware driver just released today in hopes that something magical will happen and everything returns to normal. Wishful hoping no doubt.

Again, good luck everyone experienceing the same misfortune as I am with finding a fix.

Hugh Jass Koda
 

elected

Distinguished
Nov 25, 2008
1
0
18,510
0
I have exactly the same problem with my VX922 under Vista. It worked fine over a year with my old computer with XP. Then I built a new computer with Vista x64 and the problems began. At the same time I started playing COD4. Maybe just a coincidence?

I haven't played COD4 for months now but the problems is still there and getting worse. At first I thought it had something to do with nVidia's Vista drivers but the problem occurs even during boot up. I did drop the refresh rate from 75Hz to 60Hz which seemed to help for a few months but now the black screen is back.

My warranty period has already expired so I guess I have buy a new LCD. It's just too bad because I really liked this monitor...
 

me13245

Distinguished
Dec 13, 2008
31
0
18,530
0
There is a very simple fix and you guys will slap urselves in the face when you hear it. I am useing that moniter right now. If you have another display, plug it into the computerand find the controller for the graphics card. usualy in the control pannel. go to the Viewsonic website and get the manual for the display if you dont have it. under specifcations, find the supported reulutions, and change you graphics card to out put at that rate. ive used mine without struggles for about a week now.
 

smayne

Distinguished
Dec 14, 2008
3
0
18,510
0
Me13245 - If the monitor will work some of the time, then it is not a problem with resolution. If it was set at a resolution too high it would never work on boot.

Others - I have the problem as well. My VX922 worked great, and I mean I love this monitor, for almost two years and then two months ago started doing this blinking power thing. I have been doing all of the things everyone here has mentioned with no success either.

The logical flow for me is that when it doesn't work, I can't even see the BIOS loading screens. That tells me it is not a driver or OS problem. It has to just be a hardware issue between the MB, Video Card, and possibly the BIOS.

Since we all likely have veried morhterboards (ABIT IP35 here) my guess is this is strictly a Viewsonic problem. That being said, I have swapped this monitor to another rig built similarly and have had no problems. I also swapped in another VX922 and had no problems. That would seem to rule out both my motherboard as the cause, and the monitor, and the BIOS. This is just an extemely annoying flaky issue.

I checked my motherboard post code when the problem is happening and it is C5, which appears to be an issue with Shadowing ROM. I myself have never changed any of my BIOS settings since before this started happening. I am reluctant to try to make any changes because it literally can take me 20 minutes of getting this stupid thing working again.

I love Viewsonic, and I think they make the best product on the market (especially for gaming, as I have never had ghosting issues even on ridiculous settings). I hate having to buy a new monitor, but it looks like it is coming to that. The worst part is, I would prefer to buy Viewsonic if I am going to get another monitor, but I do not want to deal with this problem happening again.

I will try the Shadow ROM disabling and report back. If some of you could possibly check your post codes on the MB and look them up. It would be interesting to know if that is a common code we are getting.

Oh .. and this is NOT a problem caused by COD4, because I have never installed it. In fact, outside of installing the LOTRO Mines of Moria upgrade, and DOSBox, I haven't changed anything on my PC since prior to this happening until now. Just an FYI on this last part.
 

drumerman

Distinguished
Dec 17, 2008
4
0
18,510
0
:D just fixed my VX922 monitor ! woot... well at first my monitor was having the same problems as everyone else's here, it would work great then just occasionally poof no longer display, i run this monitor as an extension to my 24" so it wasn't a huge deal, i could get it working again if disable the monitor, shut down, waited and tried again, but then one day it just would not come back, no error message like no source connected just sit there blinking a green light and displaying nothing.. was pretty disappointing but thought I'd google around to see if it is fixable...

I found some sites for different monitors claiming that LCD's with these symptoms (no connection error but a active light) can be because of faulty capacitor(s), which would explain why the problem is so intermediate and frustratingly hard to pinpoint, until one of the bad cap's just completely fails and then the monitor won't come back. (if you care the problem is accelerated when ever the monitor has to change its resolution, this puts the caps through a cycle which may or may not succeed with swelled capacitors, if you have a monitor that is still in the in between stage try manually changing the res, your monitor will not want to come back until it resets after it loses power.)

** fix worked for me**
Anyway to fix it you gota crack open you monitor and replace your swallon capacitors (I had 6)
What I did ~
remove the black screws on the outside, pull the back plastic panel off use knife or something it has latches, now you have 4 metal screws that hold the main board that drives the LCD, take out those screws, unplug the connections (take pictures or something to remember orientation/place to plug them back!), flip the metal thingy over to revel the bottom of 2 PCB boards, unscrew both of them but the one you want is the bigger one, this one is the power board and it has a right angle connection to the smaller PCB board, you need to wiggle it out before you can free the power board. The smaller board has the connections to your dvi vga ports so it will not come out all the way, but you only need to move it to pull out the connectors to the bigger board. (try not to touch the board just the edges), now that the boards free look at your cap's, your looking for the tops of them to be bent outwards like they are gonna explode, if they look like this they are swollen and will not longer work correctly or sometimes at all... De-solder them carefully and solder in brand new matching cap's, make sure the polarization is correct, (long leg should go to the unshaded region, short leg with - marking goes to the shaded region on the PCB board). Put it all back and power it on! Worked for me and it cost less than $5 granted i already have solder and a soldering iron. Its very likely we have similarly failed caps so the ones that failed me were:
2 - 1000uF @ 10V
3 - 470uF @ 25V
1 - 470uF @ 10V

again this worked flawlessly for me, i can change the res to w/e and it just works, so hope it works for you! good luck
(oh ya my monitor was obviously out of warranty, if yours is still good have them fix it)
~David
 

Gumby_08

Distinguished
Dec 27, 2008
8
0
18,510
0
drumerman

Thanks for taking the time to post this.

I have 3 of these monitors and each have been sent back for this very issue.

Mine aren't out of warranty yet but I hate dealing with Viewsonic (Oh boy the hours I've spent on the phone)

I'm tired of dealing with them.

I was just about to set the one that's bad right now aside and buy me a cheap monitor to replace it till it would come back,but with your response it sounds like something I'm willing to try.

I'm wondering though where did you buy your capacitors?

I have my monitor apart and can see all of the tops are pushing up.



Thanks for the help

Gumby
 

drumerman

Distinguished
Dec 17, 2008
4
0
18,510
0
man i was just about to reply lol, i ordered my caps from digikey just like you did. They got great prices though their site is pretty ugly... Nice pictures, should help others!
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS