Question Viotek GN24CB Monitor Flashes/Flickers on 120hz and 144hz

Aug 11, 2020
1
0
10
0
I've had this monitor for over a year now and this has never happened to me. I noticed that now when I set the monitor to 144hz or 120hz the screen starts to flash/flicker. I have made sure all my drivers are up to date and I have also reset my computer and changed multiple HDMI coords.
This is what it looks like-
View: https://www.youtube.com/watch?v=whWPc37kbqA
 

Zack T

Reputable
May 19, 2017
30
0
4,530
1
I have a Viotek GFT27DB that has similar issues, although I'm not entirely sure it's monitor related. I built my new computer in january this year, running with a 3800x, RTX 2080 Super, 16GB 3200MHZ Ram, ASRock X570 board, and that monitor. Ever since I got it, had some weird graphical issues. Flickering and flashing like crazy on Skyrim near water regardless of refresh rate (Although 60 makes it happen far less frequently and take longer to begin, once it starts it won't stop). WoW does it too but barely. Overwatch barely does anything glitchy but a black box/rectangle likes to appear and flicker in the top left of the screen when I first join matches oftentimes.

I thought it was the monitor but then I tried my old monitor and discovered it was still happening on that, and then even my old computer began doing the same issues.

So I'm wondering if maybe there's some kind of weird driver issue or software issue out there, maybe with ASRock motherboards (My old PC had one too) or with Ryzen's or NVIdia cards or maybe Windows 10, I have no idea.

Anyway my point was that my monitor does things too but I have no idea if it's Viotek or if it's a different cause.
 
Oct 29, 2020
1
0
10
0
I have a Viotek GFT27DB that has similar issues, although I'm not entirely sure it's monitor related. I built my new computer in january this year, running with a 3800x, RTX 2080 Super, 16GB 3200MHZ Ram, ASRock X570 board, and that monitor. Ever since I got it, had some weird graphical issues. Flickering and flashing like crazy on Skyrim near water regardless of refresh rate (Although 60 makes it happen far less frequently and take longer to begin, once it starts it won't stop). WoW does it too but barely. Overwatch barely does anything glitchy but a black box/rectangle likes to appear and flicker in the top left of the screen when I first join matches oftentimes.

I thought it was the monitor but then I tried my old monitor and discovered it was still happening on that, and then even my old computer began doing the same issues.

So I'm wondering if maybe there's some kind of weird driver issue or software issue out there, maybe with ASRock motherboards (My old PC had one too) or with Ryzen's or NVIdia cards or maybe Windows 10, I have no idea.

Anyway my point was that my monitor does things too but I have no idea if it's Viotek or if it's a different cause.
Were you ever able to get to the bottom of this issue?

I have the VIOTEK SUW49C monitor and I have similar symptoms. Toggling refresh rate from 120-144 sometimes "fixes" the issue for a bit. Then other times it just works for whatever reason for a few days at a time.

I too have the ASRock X399 board (tachi) w/ TR1950x and I have a single GTX1080TI. I am starting to think maybe its electrical interference from this motherboard / CPU / GPU combination.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS