Vista Microphone Problem

Status
Not open for further replies.

ghostdawg

Distinguished
Mar 14, 2007
9
0
18,510
First off, yes it is enabled. :D

I know how to adjust the line volume and mute, boost, disable enable. Everything is set in these properties. However as long as my mic is unmuted I can hear myself talking through the speakers. This occurs in any application(Word, IE, desktop) except the ones I want the mic to work in(Battlefield 2142, Sound Recorder, etc). In these instances the mic has no activity shown on the line indicator.

If the mic is muted or the sensitivity it is reflected in how well I hear myself in these applications. However again mic input is not recorded in the applications that is needed, ie to chat in game.
 

ghostdawg

Distinguished
Mar 14, 2007
9
0
18,510
There is no muted options under recording, only under playback, and this does nothing to fix the real issue of no applications picking up the mic, and the mic does work cause I can hear myself.

If I mute the mic under levels, which is under playback>speakers>properties, I won't hear. But to have to leave it muted when not in use, and it not working in any mic apps when unmuted isn't right.

Vista Ultimate 64
 
You like hearing yourself talk that much?

:p

The reason it should be muted under playback (and for that matter, not even selected under playback) is feedback. Not so much an issue if you're using a headset... but still I find it extremely distracting hearing my voice echo back at me when I'm using voice. Double-check your sound settings in the control panel... remember that Vista has separate volume controls for different applications. (One for Windows and one for games, if I remember correctly). Ensure that the mic is enabled when you're playing games.
 

ghostdawg

Distinguished
Mar 14, 2007
9
0
18,510
I don't care so much about the feedback, and at no time does the line indicator move while talking, and how does this get it to work in aps? Its a Creative X-fi.

It is enabled, and if i mute it under sound (can also just right click the speaker next the clock instead of control panel>sound) then great, I can't hear myself anymore, but no mic still either.
 

mjmcmahon

Distinguished
Feb 28, 2007
8
0
18,510


Based upon what I've seen with my system, BF2142 has problems identifying the microphone under Vista. I can get the microphone working in other VoIP apps (Teamspeak or Ventrilo) but BF2142's VoIP setup app will not recognize microphone input. It's likely a problem that the devs will have to figure out, should they choose to address it at all.
 

ephex

Distinguished
Jun 11, 2008
1
0
18,510
ok i have a problem,

I can get the microphone working in other VoIP apps (Teamspeak or Ventrilo)

this is my problem, i cannot get my mic to work on vista home premium for ventrilo. on one of my machines that has xp it works just fine but i cannot get a response of out if on vista premium
 

organix

Distinguished
Aug 21, 2008
20
0
18,520
you guys might want to try updating your drivers too. i was having mic problems in tf2 and other steam games for awhile, mic would work but would come across really distorted to other players and occasionally not work at all. checked using sound recorder and mic worked as normal, so it was likely driver incompatibility. installed latest drivers and everything works as it should at default settings.

If you're using your built in drivers, most likely realtek HD drivers, definitely upgrade those. It'll take some of the load off of your processor, not much but some, and more than likely solve your problem. GL~!
 

tbresson

Distinguished
Dec 12, 2008
24
0
18,510
Go into the Control Panel, click Sounds, and you should be on the Playback tab.
Dobbleclick on speakers, choose levels and notice there's a scrollbar! Scroll down to microphone and mute it.

Why Microsoft thought we should hear what we say in a microphone through the speakers is beyond my comprehension.
 

Tenoshadow

Distinguished
Dec 20, 2008
1
0
18,510
::Look EASIEST WAY OF THEM ALL RIGHT HERE::

[1] --> Right Click the Volume Icon at the bottom right corner of your screen [The Task bar].
[2] --> Click [Playback Devices]
[3] --> Right Click the [Speakers] Icon and click Properties
[4] --> Click the [Levels] Tab; and there you will see the Microphone Volume slider (The one at the very bottom of the "HD Audio output" and "PC Beep" sliders where you can un-mute the mic playback (By clicking the unmute icon, than slide the volume up to where you prefer it... Simple :) I hope I was able to help someone with this... ;)


Volume Slider:

----Microphone-------------------------
|---------------------------------[|]-------------| [_0_] [ <)) ] [Balance]
(0%) (100%)


[ OK ] [Cancel] [Apply]

(if you want your Microphone to stay on the "unmuted" setting; you may want to click apply... :)

. - - -Tenos-

..........................................................................................................................................................................
.. ______________-------.......[::<o> DIRECTIONS SIMPLIFIED <o>::].......-------______________

<|) ) ) R CLICK VOLUME ICON : CLICK PLAYBACK DEVICES : R CLICK SPEAKER ICON : CLICK PROPERTIES : CLICK LEVELS TAB : UNMUTE SLIDER AND SLIDE SOUND LVL{S} [X] :)
..........................................................................................................................................................................
 

Scorpio109

Distinguished
Dec 23, 2008
2
0
18,510
how do you get microphone to even show on your tab, my friend has vista i sadly don't and am trying to help get the microphone to show on the volume tab but am unsuccessful thus far, any help would be greatly appreciated :D.
 

confusedmusicjunkie

Distinguished
Jan 25, 2009
1
0
18,510


Hi, my problem is that in step 4 of your directions, there is no "Microphone Volume" slider, only HD Audio Output and PC Beep sliders. In other words there is no option to unmute there. There is a mic volume slider under recording devices>microphone>levels, but even when I adjust that it's still muted. I think I've looked through every "sound" related menu page, no luck. I'm using Vista Home Premium 64-bit.

However my laptop's built in mic does work when I play back a recording (as do other sound devices plugged into the external mic in jack, such as a keyboard or synth), but there is nothing coming from the speakers when using the mic in real time. This is really annoying because I used to use my old computer for recording and performing music, and in XP all I had to do was unclick "mute" in the sound properties menu. Now all my musical equipment/software is worthless if I can't hear anything while I'm recording it.

Does anyone else have this problem and know how to fix it?
 
It's not a problem... it's intentionally set up that way. I'm not sure how it works if you use an external mic, but I do know that you can't unmute the built-in mic... probably because of feedback issues. It's the same thing on my laptop... I'll have to check my desktop to see if it's the same with an external mic.
 
Well after downloading the latest Realtek driver, I now have the Realtek HD Audio Manager in the Control Panel. It allows you to unmute the mic for playback... however when I did so, I immediately had to mute it again because of feedback.

So it's possible to do, but whether it's advisable or not is another matter.
 

CoatedTrout

Distinguished
Jan 30, 2009
2
0
18,510
Hey. I can't get my mic to work at all.

It recognises it's plugged in, but I can only get the computer to recognise any sound if I repeatedly mute/unmute it.

I've got the microphone volumes and boost set to full in recording options.

Can anyone say definitively if this is a hardware problem, or have I missed something?
 
Do you have a built-in mic somewhere? Like in a webcam for instance? Windows might be defaulting to that instead of the external mic. Check your sound devices in the Control Panel and see if there are mulitple microphones. If there are, try selecting another mic.
 

CoatedTrout

Distinguished
Jan 30, 2009
2
0
18,510
I know i've got the right device selected (the two are titled 'microphone' and 'line in' - I've selected microphone) because when I unplug my mic that is the one that changes status.
 
Status
Not open for further replies.