Vista network file transfer


Sep 28, 2009
Hi all. I am having a problem with transferring large files over my network. I have a Vista SP2 laptop and a XP MCE SP3 desktop pc on a network with a wireless router(wrt54g). Until last week I could transfer large files from the vista pc(wireless) to the xp(lan). Now when I try the transfer fails at the very end, when the transfer window shows 5-10 seconds left. After a few minutes of sitting at a few seconds left, I get an error that says "Can not access the file D:\file, please make sure you are connected to the network and try again". If I try a smaller file, say less than 100mb, the transfer works fine, both vista -> xp and xp -> vista. If I browse the shared folders on the vista machine from the xp, I can transfer the large files without error. I can ping either machine from the other. File sharing is done using windows easy share, but I have tried manually adjusting the share permissions to full with no effect. I have tried mapping the drives/folders and still have the same problem, even though the drives are mapped. I have reset the router to no avail. The pc's both have fixed ip addresses that have the ip's as exceptions in the firewall(NIS 2009). I have run tests on the network cards in both machines to rule out network card failure. The only thing I have done differently, recently, is set up a second router, a wrt54g2, but it was never replaced my old router in the network, I simply ran its setup to configure it. Everything else works fine.

Anybody else run in to this or have an idea as to what may be the problem. I am almost of the opinion that it has something to do with a faulty setting in Vista and will reinstall and start from scratch, but wanted to look for something else before I go that far. TIA.