Vista slow when opening folders

Status
Not open for further replies.

deusdeus

Distinguished
Jan 3, 2006
10
0
18,510
I've been using Vista on this homebuild since Oct. 2007, and one thing I've noticed that is very annoying is that it often takes several seconds to open folders.

It seems like it is indexing every single file in the folder to determine what type of file it is or something before resuming responsiveness once you open a folder. So for example, not always, but oftentimes when I open my Downloads folder, which has a lot of files, it will take several seconds to fully display and become responsive.

I'm running a Q6600, 4GB RAM, 8800GT. Vista Home Prem. 64-bit.

Any solutions?
 
Yea, several seconds is a long time - I just opened up a massive directory of about 180 gig and a bunch of files and it pops up instantly. So I would guess something is running that is slowing things down. Could be a resource hogging A/V program or it could be malware or something along those lines. See if it happens in safe mode. If not then you have a clue that a bkg process of some sort is probably causing it.
 

randomizer

Champion
Moderator
Nice old thread. Hmm... I always found that Vista was dog slow opening my Downloads folder too. It didn't even have much in it, and it was only that folder. Never worked out why it would lock up when opening the folder for the first time after each reboot.
 

tphive

Distinguished
Oct 17, 2009
1
0
18,510
I have the same problem with Seven, anyone find a solution for this issue? It's a bit of an annoyance. :\

And it does seem to only be the Downloads folder for some reason as a well. Regardless of how many files are actually in the folder, be it 300 or 30.


Tom
 

jonmboxer

Distinguished
Feb 17, 2009
4
0
18,510
My fiance has the same issue with her Vista PC. Outlook 2007 takes forever to open, when saving attachments from an email it takes forever. When viewing photos it takes forever for it to initially open. She uses Story Book Creator and Memory Manager for her photos, which she has around 13,000 photos on her pc. Could that be the cause of the slow loading?

# Genuine Windows VISTA Home Premium 64-bit
# 2GB DDR3 System Memory (2 Dimm)
# Intel(R) Core(TM)2 Duo Processor T6600 (2.2GHz, 2MB L2 Cache, 800MHz FSB)
# 250GB 7200RPM SATA Hard Drive with HP ProtectSmart Hard Drive Protection
# 512MB ATI Mobility Radeon(TM) HD 4530

Those are her computer specs (roughly, I just copied and pasted from the HP site as I can't find her's for some reason).
 
Status
Not open for further replies.

TRENDING THREADS