Vista Won't Detect USB


Jun 13, 2009
If this is in the wrong section, please move it :)

Hello, Long time no See :)

I, um, Run into a problem.

My Vista refuses to commuicate with any USB device connected to it.
But first, let me do what I do best: Explain :D

Ok well I was playing a game with my recently brought Logitech Gaming Controller
It worked when I first installed it, and all my games worked with it too.

One day (like 3-4 days ago), I came out my room to spend time with my brothers and to play a little Resident Evil 4.
I connected the controller, and launched the game.

I started playing, got to a point, and my sis asked if this CD worked.
I saved, exited, and unpluged the controller. I checked the CD, gave it back, and relaunched the game.
I plugged the controller in and tried moving, but it didn't work. Well, plug the controller in THEN launch the game (As it needed with The Simpson)

Unplugged the controller, exited, plugged in the controller, and launched the game. It still wouldn't work.

Ok, well the Windows Game Controllers didn't detect the Controller. When I ran the software that came with the Controller, it said it wouldn't detect it.
I uninstalled the software, reinstalled, and tried, with failure.

I restarted the computer, ad when it came on, for the first time, ESET complained about: Error, unable to connect to Kernel ect

I tried the Controller, still no.

I connected their website, asked for help, they said to do what I already did: Restart and reinstall software.

Waiting for a reply, I did some stuff:
Uninstall as much crap as I can.

Tried again, nope. Although I'll point out that the controller light when button pressed, still comes on. So it powers it.

Some other stuff I tried:
Running Registry Cleaner
Virus Scan
Disk Clean

I got a reply to call their place.

So I went on Google and searched Vista wont detect USB and clicked the first 5 results
None helped, and the one on yahoo I tried.

So today I took a picture with my camera, connected to computer awaited for the popup thingy.
Nothing happened?
I tried connecting my PSP

I tried different ports by the way. Nothing

So, somehting is wrong with my Computers USB Ports

(And about the controller, I connected it to my Other working Computer, and detected it and fully does the camera.....)

What happened? Why is my Ports no Working?
I have like, 20 games I wanna play but can't cause I can't use the Controller (And I thought it broke, silly me)

Please help.
My Specs:

Windows Vista Ultimate
Toshiba Computer
3 USB Ports
160GB HDD, Used: 140GB

Thank You



May 30, 2006
Nice thread with good detail of whats happening, Unlike someothers on this lol

Well, have you checked in device manager to see that there are no problems (hardware with a yellow Exclaimation) check in there i suspect that you have might have a problem with the USB hub controller


Jun 13, 2009
Thank you for the reply.

That's one of the spots I checked after some googling.

Unfortunately, nothing is out of order. Only thing out of place with a yellow sign is:
Other Devices
-SM Bus Controller
-Video Controller

Which state is not installed, but will not update either..I will check that with a backup copy and update this when I get a chance.
Here's a picture.

And, I forgot to mention this:
When I shut down the computer, and launched Windows 7(brand new, nothing added or changed) I connected the PC Controller, to find the USB error message came up. Saying something like it doesn't work. I don't remember I'll try again and update.