Vista wont recognize external hard drive in disk management


Apr 1, 2010

I have a Fujitsu Storeagebird 35EV840 which a Vista Home Premium lap top is refusing to recognise, either in Explorer or in Disk Management. I plugged the hard drive in to a Vista Ultimate machine, where it was recognised in disk management and a quick format meant it was visible.

If I can't see it in disk management, I'm a bit stuck as to what to do next. Any ideas?



Oct 19, 2006
For starters, check this thread:

and my post on 5-25-2009. Note that a brand new empty HDD will show ONLY in the LOWER RIGHT pane of Disk Management. You can work on it there.

Now, that post was for someone whose drive had never been Partitioned and Formatted. However, you say you think you succeeded in formatting this HDD in another machine. I have to guess it also established a Partition, since that is required before a Format can be done. If you find that, with this drive mounted in the laptop, it shows in the the Lower Right pane of Disk Management, look at its horizontal block carefully. At the left end is a small label block. To the right is a large block representing the Partition you previously Created and Formatted. It will have info about the size of the Partition, its letter name, its File System, etc. Does it have a letter name? If not, RIGHT-click the Partition and give it one. Then back out of Disk Management and reboot. What about the File System? If it shows you NTFS or FAT32, you're probably OK. But if it shows you RAW, there is some corrupted info in the Partition data on the disk. In that case since you do not have any useful data on it yet, I suggest you start over. Right-click on the Partition and choose to Delete the Partition. Do this again if there are any other Partitions, until there are none. Then right-click again and Create a Primary Partition, setting its size to what you need - maybe all of the disk. If this will be just a data storage device, you do not need to make it bootable. If you are in a wizard you probably also have options to choose for the Format operation. Use an NTFS File System, and a Quick Format should be OK. When it's all done, back out of Disk Management and reboot.

Similar threads