Question Visual Studio runtime problems

Feb 7, 2020
7
1
15
0
This isn't the first time I've had this issue, but previously I tackled it on WinXP and that wasn't so bad. Now it's Win7 time and far more of a headache than I remember it being. I'm yet to dive into the registry and hack chunks out of that, but I may have to resort to that... This all started when needing to install the 2019 runtime for UE4.

Some runtimes are refusing to uninstall, and some newer releases are refusing to install unless that happens.
I run into this error:-

Windows Installer

The feature you are trying to use is on a
network resource that is unavailable.




And here's a list I've made of the packages that are being stubborn:-

__

2005 x86:-
..\\Users\___\AppData\Local\Temp\IXP001.TMP\vcredist.msi
560KB

2008 9.0.30729.6161 x64:-
..\\dc2935d289eddfed8abe7f5a57\vc_red.msi
788KB

2008 9.0.21022 x86:-
..\\db2e604ea13629ba9f36e7d1\vc_red.msi
2.06MB

2008 9.0.30729.17 x86:-
..\\1db3a11f542711aa258f8d39c90e\vc_red.msi
594KB

2008 9.0.30729.6161 x86:-
..\\c3d074dacbfc78a3885977c0\vc_red.msi
600KB

2010 10.0.30319 x64:-
..\\e370fe1f9610bf9212639a92\vc_red.msi
13.6MB

2010 10.0.40219 x64:-
..\\32ca29e0ac6330298a58c1\vc_red.msi
13.8MB

2010 10.0.40219 x86:-
..\\8aa5c006360cf2ac3ed515\vc_red.msi
11.1MB

2013 12.0.40664 x64:-
..\\ProgramData\Package Cache\{929FBD26-9020-399B-9A7A-751D61F0B942}v12.0.21005\packages\vcRuntimeAdditional_amd64\vc_runtimeAdditional_x64.msi
?MB

2013 12.0.40664 x86:-
..\\ProgramData\Package Cache\{F8CFEB22-A2E7-3971-9EDA-4B11EDEFC185}v12.0.21005\packages\vcRuntimeAdditional_x86\vc_runtimeAdditional_x86.msi
?MB

2019 14.25.28508 x64:-
..\\ProgramData\Package Cache\{B0037450-526D-3448-A370-CACBD87769A0}v14.11.25325\packages\vcRuntimeMinimum_amd64\vc_runtimeMinimum_x64.msi
?MB
__


Others uninstalled without any complaints, but these just will not.

It's ridiculous that Microsoft put these files into temp folders, or even worse - into root directories, and expect them to still exist months or years later, and outright refuse to uninstall otherwise! The pages and pages I've read about similar issues - Microsoft support are the LAST people who know what the hell is going on. "Reinstall Windows" is a common 'final solution'. Oh yeah, and then what, start from scratch just to crash head-first into the same brick wall all over again? Thanks...

I've tried some all-in-one solutions and a "total uninstaller" I found, but none of them solve the issue. The Windows Installer dialog pops up and expects an MSI file. Links:-
https://www.softpedia.com/get/Programming/Components-Libraries/Visual-C-Installer-Uninstaller.shtml
https://www.majorgeeks.com/files/details/visual_c_runtime_installer.html
https://github.com/Microsoft/VisualStudioUninstaller/releases

I've tried tracking down the MSI files, both online and locally, but no luck there. I've tried to extract the EXEs but I don't get proper filenames when doing that. Perhaps one of the extracted files is the MSI file but I have no idea how to identify it. It doesn't seem to be the case.

Anyway, I thought I'd try to post this here too, and maybe some of you might be kind enough to scan your systems for these MSI files, package them up and send them my way somehow? Thanks.
I'll be sure to follow up on this if/when I find a non-nuclear solution.

.
.
.
 
get your packages from ms, not techgarbage.com

there are log files in the TEMP directory that will tell you what is going wrong. I am not even sure if you CAN install that runtime on Win7. You need windows 10

if you hack chunks out of your registry then you deserve a failing system, leave that alone.

Visual Studio 2019 will install and run on the following operating systems (64 bit recommended): Windows 10 version 1703 or higher: Home, Professional, Education, and Enterprise (LTSC and S are not supported) ... Windows 7 SP1 (with latestWindows Updates): Home Premium, Professional, Enterprise, Ultimate. Windows 7 SP1 (with latestWindows Updates): Home Premium, Professional, Enterprise, Ultimate.

https://www.quora.com/Will-Visual-Studio-2019-run-on-Windows-7

you probably do not have the updates necessary. it should run otherwise I think,
 
Feb 7, 2020
7
1
15
0
So, I went ahead and ripped some guts out of my registry - references to those 'serialised' folders a particular installation was looking for.
Rebooted, tried to install, and bam - it behaved nicely!!!
And now Unreal Engine is actually launching instead of sitting twiddling its thumbs from the launcher. So yes, it did work and yes it's supported on Windows 7.

A side-effect is that the package extracted and made itself at home in my root Y:, of all places. I don't know why, maybe because it has the most free space? Well, Microsoft, don't expect me to just leave all that junk there. What I recommend is a tool to fix these issues with ESPECIALLY these runtimes, which are vital system files that many pieces of software requires to run. I would even do it myself if I was skilled enough to.

If anyone else stumbles on this and has the same issue, please consider the following advice:-
- A system restore point, even just 1.
- Image your C:\ with something like Acronis True Image.
- Backup your registry with something like Acelogix Registry Backup.
...only then attempt to rip chunks out of your registry, in a desperate attempt to right the wrongs of Microsoft.

.
.
.
 
Thread starter Similar threads Forum Replies Date
New Guy Here Windows 7 0
New Guy Here Windows 7 3
E Windows 7 2

ASK THE COMMUNITY

TRENDING THREADS