Warcraft III won't launch in Windows 7

F_Pastor

Honorable
Aug 11, 2012
53
0
10,630
0
I've installed Warcraft II on my new computer that's running on Windows 7 64-bit Home Premium, but it won't let me launch the game. Instead, it gives me an error message saying that it is

"Unable to initialize DirectX. Please ensure that you have installed DirectX 8.1 or higher and that your display drivers are up to date..."

"Please verify that your Warcraft III disc is in your CD_ROM drive, then click on 'Retry'."

I have DirectX11 installed and my EVGA GTX 560 video card has its drivers up to date. I initially had the CD-ROM in the drive, but I uninstalled it and downloaded the game client off of battle.net, hoping that would fix the problem. Unfortunately, the problem persisted.

I have installed it in compatibility mode with Windows XP SP2 and I have also tried running it in compatibility mode with Windows XP SP2 and SP3, and Windows 2000. I've also checked dxdiag and it tells me that there are no errors and I cannot disable or enable Direct3D like some answers I have found online.

I have no idea why this game isn't working and I'm hoping you guys could help me.

Can I really not play Warcraft III, or is there a solution to this?

Thanks

-Francis
 

F_Pastor

Honorable
Aug 11, 2012
53
0
10,630
0
Figured out how to fix my problem, if anybody has the same thing.

Try right-clicking on the shortcut, go to "Properties", and in the "Target" dialog box, add
"-opengl" to the end (without the quotation marks, obviously).
 

The_Epigone

Honorable
Sep 27, 2012
2
0
10,510
0


Ok I have had the EXACT same problem as you and have tried all of the solutions you have mentioned.

This last one you posted is different than what I've seen before but I can't get it to work. What exactly do you mean by it?

This is what appears in my Target box in Properties:

"E:\Warcraft 3\Warcraft III\Warcraft III.exe"

where do i add the new stuff?
 

Clarence_24

Honorable
Nov 9, 2012
2
0
10,510
0

 

iqsoft

Honorable
Feb 9, 2013
2
0
10,510
0
Right click the shortcut of the war3 icon and you should see

D:\WarcraftIII\war3.exe

The D:\WarcraftIII would represent the directory you installed warcraft in

You need to add the following to it

D:\WarcraftIII\war3.exe -opengl

No quote, nothing, just add -opengl

Let me know how it went!
 

00device

Honorable
Aug 13, 2013
1
0
10,510
0
The problem is with the intro movie.
Windows 7 can´t play the intro movie so it crashes and return to the desktop.
Add this key to the registry to tell the game that you have seen the intro already. So the game starts normally.

[HKEY_CURRENT_USER\Software\Blizzard Entertainment\Warcraft III\Misc]
"seenintromovie"=dword:00000001
 

KardasDragon1321

Honorable
Jul 22, 2012
47
0
10,530
0
You need a little piece of software to get Warcraft to run properly. First of all download the Warcraft 3 patches from Blizzards site and install them. It wont work when you try open it up but you will get the necessary files there. To get them to work you will need this: http://www.engamers.com/download-warcraft-iii-fixer-w3fixer/ it will fix Warcraft patches for you. I did this maybe a year back and i dont remember if those are the exact steps. Just google a youtube vid about the Warcraft 3 Fixer and a proper guide should show up. I hope this helps

Patch link: https://us.battle.net/support/en/article/classic-game-patches just select WC3
 

anxaa_info

Reputable
Feb 20, 2014
1
0
4,510
0


 

ninz26

Honorable
Jun 27, 2013
2
0
10,510
0


Well ... I HAVE FIND THE SOLUTION ! This really works for me . I'm using Warcraft 3 Portable , so already fullversion . I've used Warcraft Version Switch and i've downloaded the patch and then i switch the Warcraft 3 version with WVS and with the patch . And , you must add -opengl in the end ^_^

 

Gain32

Reputable
Apr 30, 2014
1
0
4,510
0
I cant open my war3, It just stuck on war3 launcher then nothing happens, I tried using the -opengl thing and it opened but on the main menu it has lower graphics.lags and lower brightness than the usual thing I play when i was using my older pc. Please help me
 

ripper803

Reputable
May 2, 2014
1
0
4,510
0
i was able to open the game by adding -opengl to the end. the intro movie played fine, but there is a ridiculas amount of lag. like 2 seconds lag between screen movement at least. its not my computer because i used to have it on it and it ran perfectly then. any help?
 

jayyL

Reputable
Jan 17, 2015
1
0
4,510
0
I followed your instructions but as I click warcraft 3 frozen throne it will just turn my screen to black and then it will go back to desktop then nothing happend
 

you868

Reputable
Mar 9, 2015
1
0
4,510
0

I have the same problem. Anyone know how to fix this??????????????? Please help!!!!!!!!!!
 

shengboyz

Reputable
May 19, 2015
1
0
4,510
0


i have done it and open warcraft successfully ,but it is another problem the graphics is lousy and it is laggy
 

ASK THE COMMUNITY

TRENDING THREADS