WARNINIG! MS Updates deleting ADD OR REMOVE PROGRAMS

G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.basics (More info?)

I've installed all the latest XP updates on several workstations and
the ADD OR REMOVE PROGRAMS feature is getting screwed-up.

It will show the first group of about (5) installed apps and then it is
blank.
You will have scroll all the way down the page and you find the others.
But there will be some that are not showing up.
This has happened on several of my PC's.
Has anyone else had this problem yet?


Terry
Desktop Support Technician
Dallas,TX
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.basics (More info?)

See if this helps you

Why does Add or Remove Programs show a large blank space?
http://blogs.msdn.com/oldnewthing/archive/2005/05/26/422076.aspx


If it is one of the first five entries, like you are saying, it's probably
not one of the Windows updates that has the screwed up registry entry (well,
I'd be surprised if it was)

--
Gary Tsang
Microsoft MVP - Windows XP Shell/User
http://www.microsoft.com/mvp


<terry75115@yahoo.com> wrote in message
news:1126018794.506196.145040@g44g2000cwa.googlegroups.com...
> I've installed all the latest XP updates on several workstations and
> the ADD OR REMOVE PROGRAMS feature is getting screwed-up.
>
> It will show the first group of about (5) installed apps and then it is
> blank.
> You will have scroll all the way down the page and you find the others.
> But there will be some that are not showing up.
> This has happened on several of my PC's.
> Has anyone else had this problem yet?
>
>
> Terry
> Desktop Support Technician
> Dallas,TX
>
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.basics (More info?)

Same answer as in

microsoft.public.windowsxp.help_and_support

If a message MUST be posted to multiple groups, post a single message and
select all the groups (or type their names manually, separated by commas) in
which you want it to be seen. This is called Crossposting and when used
properly it is *GOOD*.

This question was posted individually to multiple groups.

This is called Multiposting and it's *BAD*.

Replies made in one group will not be visible in the other groups, which
may cause multiple people to respond to a question with the same answer
because they didn't know someone else had already done it.

This is a waste of time.
-----

Do the programs end at particular letter in the alphabet? A maybe? If so,
you may have a huge white space, scroll down in Add or Remove Programs to
see if this is the problem.

If it is...

Courtesy of Kelly
Microsoft-MVP Windows® XP-Shell/User
2004 Windows MVP "Winny" Award

Add or Remove - White Space
http://www.kellys-korner-xp.com/xp_a.htm#ws

[[This is generally due to the DisplayIcon having a negative number. From
here you can either remove the negative number or remove the last
application listed:
Start/Run/Regedit:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{} ]]

AutoCad Fix
http://www.kellys-korner-xp.com/regs_edits/autocadaddremovefix.zip

Autodesk Land Desktop 3 Fix
http://www.kellys-korner-xp.com/regs_edits/autodesk-landdesktop3-addremovefix.zip

===

I have AutoCAD LT 2000i. The white space in Add or Remove Programs usually
shows up after the AutoCAD LT 2000i listing. If you want to tweak the
registry...

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\
{5783F2D7-0065-0409-0000-0060B0CE6BBA}
Value Name: DisplayIcon
Value Type: REG_SZ
Value Data: C:\Program Files\AutoCAD LT 2000i\aclt.exe,-1

Notice the aclt.exe,-1?? You can change it to read aclt.exe,1

Or you can run one of the fixes. I have both autocadaddremovefix.zip &
autodesk-landdesktop3-addremovefix.zip. They both include icons.
autocadaddremovefix.vbs is the one that works for me. It's easier to use
the fix than changing the -1.

I get the white space in Add or Remove Programs every time that I add or
remove a program. It isn't always AutoCAD LT that has the white space after
it, sometimes it's another program. At any rate, one of the fixes will
work. Until the next time.

autocadaddremovefix.vbs adds an autocad.ico icon to the %systemroot%\web
folder. It also adds this to the registry >>
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\
{5783F2D7-0101-0409-0000-0060B0CE6BBA}
Value Name: DisplayIcon
Value Type: REG_EXPAND_SZ
Value Data: %systemroot%\web\autocad.ico

autodesk-landdesktop3-addremovefix.vbs adds an acad.ico icon to the
%systemroot%\web folder. It also adds this to the registry >>
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\
{5783F2D7-0138-0409-0000-0060B0CE6BBA}
Value Name: DisplayIcon
Value Type: REG_EXPAND_SZ
Value Data: %systemroot%\web\acad.ico
-----
***
From snowman...
AutoCAD 2002 is
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\
{5783F2D7-0101-0409-0000-0060B0CE6BBA}
-----
***
From anonymous poster...

One application causes the problem for me. I just removed the reference to
that program in regedit and the black spot dissapeared.
-----

Here is a script which lists all the negative icon references and sends them
to a log file.
http://windowsxp.mvps.org/utils/
ARPNegCheck.vbs
Lists all negative icon references in Add/Remove

http://windowsxp.mvps.org/reg/ARPNegCheck.vbs

From...
Ramesh, Microsoft MVP
Windows XP Shell/User
http://windowsxp.mvps.org

Dowload the script. Run it by double clicking ARPNegCheck.vbs.
NegativeIcons.txt will be saved to your Desktop.


--
Hope this helps. Let us know.

Wes
MS-MVP Windows Shell/User

In news:1126018794.506196.145040@g44g2000cwa.googlegroups.com,
terry75115@yahoo.com <terry75115@yahoo.com> hunted and pecked:
> I've installed all the latest XP updates on several workstations and
> the ADD OR REMOVE PROGRAMS feature is getting screwed-up.
>
> It will show the first group of about (5) installed apps and then it is
> blank.
> You will have scroll all the way down the page and you find the others.
> But there will be some that are not showing up.
> This has happened on several of my PC's.
> Has anyone else had this problem yet?
>
>
> Terry
> Desktop Support Technician
> Dallas,TX
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.basics (More info?)

I fixed it!!!!!

I was in the wrong location.
I was in DISPLAYNAME looking for a -1, but it is DISPLAYICON.

Thanks fellows

Terry
Desktop Support Technician
Dallas,TX
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.basics (More info?)

Glad to hear that you fixed it. Remember how you did it because it will
happen again.

Keep having fun.

--
Hope this helps. Let us know.

Wes
MS-MVP Windows Shell/User

In news:1126193900.733733.76870@z14g2000cwz.googlegroups.com,
terry75115@yahoo.com <terry75115@yahoo.com> hunted and pecked:
> I fixed it!!!!!
>
> I was in the wrong location.
> I was in DISPLAYNAME looking for a -1, but it is DISPLAYICON.
>
> Thanks fellows
>
> Terry
> Desktop Support Technician
> Dallas,TX