Question Was my motherboard damaged by power fluctuation?

MashedPotatonator

Reputable
Sep 12, 2015
4
0
4,510
0
I've been having many problems with my computer recently. Sometimes I would be using it normally when it would suddenly freeze out of nowhere. If I have sound playing when it happens, the freezing is accompanied by a loud never ending buzzing noise, thus forcing to switch it off an on again. Doesn't really matter what I do. It has happened while just browsing the internet, gaming and even just idling. I built the computer last November and it ran with no issues even during very long gaming sessions. Only recently (maybe the last 2-3 months) has it started to act up frequently.

Another issue I've had is where the computer would boot loop. I press the power button, fans spin, then stop. Fans spin, then stops. Over and over again... I've done everything from uninstalling all components and even taking the motherboard out of the case and attempting to start it. Sometimes it would work after letting it boot loop for 5-30 minutes. I've also tried 3 different ram sticks and using the onboard graphics instead of my gpu. Problem still persists.

I'm leaning towards the fact that the motherboard may have been damaged due to voltage fluctuations which is very common where I live. (My lights and electric fan would slow/dim down every now and then). I'd really appreciate if I could get any help with this.

Specs:
i5 2400
ASRock H67M
3 Different sticks of ram (1 Kingston, 1 HyperX, 1 Ramaxel)
EVGA GTX 960
Seasonic S12II 520W
 

Lutfij

Titan
Moderator
By 3 different sticks of ram, are you saying that they are mixed and matched on your system? If so, stick to one stick and see if system stability is found. Might want to also state the age of your Seasonic PSU. Latest BIOS update for your motherboard?
 

MashedPotatonator

Reputable
Sep 12, 2015
4
0
4,510
0
I usually have the Ramaxel and HyperX stick installed at the same time. I've also tried running one stick at a time but it still doesn't want to boot. The power supply was manufacured in 2015 according to the serial number. BIOS was also updated on the motherboard as soon as I built the system
 

ASK THE COMMUNITY