• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Meet Stan Dmitriev of SurrogateTV on the Pi Cast TODAY! The show is live August 11th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Professional PC modder Mike Petereyns joins Scharon on the Tom's Hardware Show live on Thursday, August 13th at 3:00 pm ET (8:00 PM BST). Click here!

Question Water spilt on pc tower

Jul 12, 2020
3
0
10
0
Hi, so I had spilt a cup of water and around 1/8 of the water went into the top of the pc, I turned it off immediately and sprung into action, I took of the glass from the sides and dried everything I possibly could, everything is running, my graphics card turns on and glows, along with the fans on the graphics card and my motherboard’s fans, all of the fans turn on, everything that lights up will light up, but I don’t see any display output on my monitor, so I tried a different monitor and it still didn’t work, so I thought maybe something was wrong with my monitors? Nope, I plugged them into my cable box with the same hdmi cable I use for my pc (my dad works from home now so he has to use my monitor for a double monitor setup so I use my tv, so that means that I have to use hdmi, but he brought my monitor up to check) but the display showed up for my cable box so I know that it isn’t a problem with my tv or monitor. I then thought to maybe take out my current graphics card and replace it with my old one to see if it was the graphics card that was the problem since that’s what I always plug my display into, so I reinstall my old graphics card and I still got no display, I tried using display port and dvi as well on my monitor with both graphics cards and it still didn’t show up, do you guys know what I could do? Quick little story about what happened after I tried everything, I was turning my pc tower the other way to put it where it was but a cable that was connected to my tv got caught and my tv came flying down and it shattered, it was a hard day as you could tell.
 

stonecarver

Upstanding
Nov 18, 2019
417
60
390
33
I would pull the power cord and than hold down the power button for 20 sec to drain caps and than re test. If still not working do the same but this time pull motherboard battery do the 20 sec with no battery. Put battery back in, re test. If still not working do you have another PCI-E slot move card to there and test.

Also are you sure everything is dry?
 

hang-the-9

Titan
Moderator
Decent chance motherboard is dead, where did the liquid get to? Anyplace it did you have a good chance that part got fried. Was there any odd smells from the system? Not sure why you would have checked your monitor as the issue after spilling something in the computer, it's like crashing a car then going inside your house to check if your couch was OK. How long did you wait to dry things before turning system back on? Did you remove everything like video card, RAM, power plugs while letting the system dry?
 

ASK THE COMMUNITY

TRENDING THREADS