Watercooling Issue, Please Help

Shawn Caution

Reputable
Jun 23, 2015
2
0
4,510
0
Hey everyone. I’ve been trying to solve this issue on my own for a couple of weeks but the issue is becoming such a confusing problem.

First, thought my computer was overheating and needed a flush and thermal repasted. So after adding new thermal paste to the CPU rehooking the PETG tubing up. I added distilled water to flush the system and the pump didn’t turn on. I knew it was either the pump or thermals. Okay. So, only thing I could do was just take the pump off the reservoir and see if it was gunked up. There was nothing, made sure it was dry and clean. Hooked it back up, added distilled water to the reservoir, turned the computer on and it magically started pumping....okay????

So, added distilled water and pumped it through the system for a couple hours. Then drained it and added the PrimoChill Vue. Everything worked fine. Ran the computer for 6-7hrs then I shut it off, go to bed, woke up, turned on the PC and the pump wasn’t working. So, I was like okay...it must be the SATA hooked to the PSU, found another cable and hooked it up. Nothing. Last resort was to drain it, so I drained it. Took the pump off the reservoir again and cleaned it, but there was nothing gunked or stuck inside of it. Hooked it back up to the reservoir and now it works again. I don’t know what to do...I can’t just do this every time I use my computer. I’m stumped and don’t know what to do. Can anyone give me any suggestions or have had a similar issue?



Ps. The liquid prior to PrimoChill was Thermaltake High-Performance C1000.

Watercooling: RayStorm D4 Photon

CPU: Gigabyte Z370 AORUS Gaming 7

PSU EVGA SuperNova 850 G2

Pictures of System and Resevoir: https://imgur.com/a/jUfPZv5
 

rubix_1011

Contributing Writer
Staff member
Pic of temps seems fine - is this just to show it works OK when it does?

Does the pump always power on when your system turns on, or does the pump not power at times? This would be the very first item that should provide whether or not you should proceed to any other troubleshooting.

If the pump ALWAYS runs when the PC is on, it isn't power that is the issue, it is likely some form of restriction or air lock causing the problem. There seem to be more 90 degree fittings than really are necessary, but I don't think there are enough to cause an excessive amount of restriction and reduction in flow. One indicator is that when you drain/disconnect the pump from the loop and then put it all back together, it works...if you vent or open the top of the reservoir fill cap, does the flow work? Is coolant flow through the CPU block using the correct In and Out ports? Often times, CPU blocks have a dedicated flow route and running this in reverse actually works poorly.
 

Similar threads


ASK THE COMMUNITY