[SOLVED] way too much input lag with vsync on and too much screen tearing with it off

a-guy

Prominent
Aug 17, 2019
111
2
615
8
So i have a decent laptop it has a i7 7700HQ + 1050Ti + 16GB of ram and a 500 GB SSD but the laptop is also from dell so its more like sonic trying to run with one leg anyway i tried playing cs:go and the thing about the laptop is that it has insane screen tearing so naturally i tried vsync and after that i noticed i have a full half second of input lag and thats really bad for cs:go because at that point its hard to shoot the chickens running around and to be honest i have no idea how to make it run "smooth" i have tried all versions of vsync, fps limiter, undervolting the cpu and several things you can find on those youtube tutorials to make your pc run better except i didnt do anything to the registry because its risky and the laptop is already running at its worst after 2 years of use. Anyway if anyone has a clue how to get rid of screen tearing without using vsync please tell me.
 

boju

Titan
Ambassador
Try use fps_max command in csgo to 59 instead of using riva. Without riva and csgo set to 59, then try the vsync options i mentioned. Probably best use the game's own vsync as appose to Nvidia's.
 

a-guy

Prominent
Aug 17, 2019
111
2
615
8
Try either Nvidia vsync / fast sync and the game's own vsync with Nvidia set to application control. Try each but limit fps to 59. See how you go.
So i tried the nvidia vsync only and honestly it probably made it worse, then i wanted to try the fast sync but i dont have that option so i cant try it and last i tried the nvidia application control + double buffer and so far that was the most playable option and the weird thing about it is that it feels like something is off but i cant tell what it is and when im looking around everything is blurry and if i look really close i can see that everything on the screen leaves "dust" behind it, is that normal? Other than that i can tell the input lag is there but its not that bad i guess i could get used to it after some time but if you got anymore ideas please tell me if you dont know anything else that could help i guess i could just mark your answer as best and leave it at that. Also i used rivatuner on all of those options and limited my fps to 59.
 

boju

Titan
Ambassador
Try use fps_max command in csgo to 59 instead of using riva. Without riva and csgo set to 59, then try the vsync options i mentioned. Probably best use the game's own vsync as appose to Nvidia's.
 

a-guy

Prominent
Aug 17, 2019
111
2
615
8
Try use fps_max command in csgo to 59 instead of using riva. Without riva and csgo set to 59, then try the vsync options i mentioned. Probably best use the game's own vsync as appose to Nvidia's.
with the fps set to max 59 ingame, nvidia set to use 3D app settings and ingame vsync set to double buffer i cant see a single tear and the input lag is almost not there, the only bad thing i noticed is that when i alt+tab out of the game and back in i get really bad input lag for 3 seconds and that "dust" effect is almost gone too and i think thats about as good as it can get. Thank you for your help
 

ASK THE COMMUNITY

TRENDING THREADS