WD Blue 4TB cannot initialize, Not detected In BIOS, shown as "Unknown Device" In windows 10 64 bit.

Dec 1, 2018
1
0
10
0
My WD Blue 4TB drive that i just bought from Newegg cannot be detected in the BIOS. Everytime i switch on my PC, my motherboard will show disk drive error and will ask me to run the diagnostics, but it will only show my other harddrive, which is used as my boot drive. Since it can't even detect my WD Blue drive, running the diagnostics would be useless.
It is detected in Windows 10 64 bit as "unknown device" in the disk drive section of device manager. Tried updating the driver by finding drivers online. It says its the latest. My windows is also updated.

It cannot be initialized on Windows administrative tools. It shows up as Disk1 in my Disk Management screen and it is "unknown". Trying to initialize it by using either MBR or GPT has failed. I know that it is supposed to be initialized by using GPT, but when i try to, it returns "The specified disk is not convertible because the size is less than the minimum size required for GPT Disk.

I've tried using the Western Digital LifeGuard Diagnostics Tool for windows but when i try to run either a quick test or extended test, both will fail in less than a second and will show the error "SMART Enable Operation error!". My attempt to ERASE the drive also failed, showing a "Delete Partitions Error!"





I'm currently using a motherboard that was inside a HP Pavilion Computer.
Yes i have tried using a different SATA Port.
Yes i have tried using a different SATA Cable.
Yes I am sure that my PSU fed the hdd with enough power.

So did i receive a dead harddrive?
Should i just return my wd blue 4tb back to newegg as an RMA ?
I am receiving a new motherboard and a new CPU soon. Should i not return it now and then test it on my new motherboard and cpu?
Thanks for reading and replying if you know about the problems i'm facing. Thanks
Here are some screenshots i've taken https://imgur.com/a/PzPVSNk
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS