[SOLVED] WD Blue NVME drive 500gb not being recognizied at all?

The_BlackHusky

Commendable
May 29, 2017
6
1
1,515
0
Hi,

so to put this all into context I recently (Less than a week old) brought an entire gaming system excluding the graphics card because I already own one.

Inside this system is;
  • CPU - Ryzen 5 3600
  • MOBO - TUF B450-PRO Gaming Motherboard
  • RAM - Corsair Vengence Pro 8x16GB DDR4 3200MHz
  • AIO - Corsair H100i Platinum
  • STORAGE - Corsair MP510 240gb (Boot Drive)
  • STORAGE - WD Blue 3D NAND SATA SSD M.2 2280 500gb (This drive is not being recognized at all)
  • PSU - 650W EVGA SuperNova G3 80+
  • CASE - H500 NZXT White
After removing the Nvme drive and reinstalling it nothing shows up...
Looking through device Manager > 'Other Devices' > I get two PCI Device Unknown, yet cannot install drivers for them.
then looking at device Manager > 'Disk Drives' > 'Force MP510', is my only option.

I have tried disabling CSM in bios but then cannot boot from the MP510 boot drive.

Anything I have missed?
Anything In bios may help?
Have I overlooked anything?
Or is the drive dead and I need to request a replacement?

Regards,
Anthony

P.s sorry for the large amount of information but I feel like its needed...
 

USAFRet

Titan
Moderator
Mar 16, 2013
130,893
5,560
165,040
20,198
One port supports both SATA and PCIe drives.
The other supports only PCIe.

Your WD Blue is a SATA M.2 drive.
Which port do you have the drives in?


AMD Ryzen™ 2nd Generation/ Ryzen™ with Radeon™ Vega Graphics/ Ryzen™ 1st Generation Processors :
1 x M.2 Socket 3, with M key, type 2242/2260/2280/22110 storage devices support (SATA & PCIE 3.0 x 4 mode)*2

AMD B450 chipset :
1 x M.2 Socket 3, with M Key, type 2242/2260/2280 storage devices support (PCIE 2.0 x4)*3
 

The_BlackHusky

Commendable
May 29, 2017
6
1
1,515
0
"After removing the Nvme drive and reinstalling it"
Why removing and reinstalling? Same m.2 slot, or the other one?
Okay, now I just realised placing it in the same slot changes nothing at all.

But the other m.2 slot is occupied, so unless I swap what else am I to do?
 

USAFRet

Titan
Moderator
Mar 16, 2013
130,893
5,560
165,040
20,198
One port supports both SATA and PCIe drives.
The other supports only PCIe.

Your WD Blue is a SATA M.2 drive.
Which port do you have the drives in?


AMD Ryzen™ 2nd Generation/ Ryzen™ with Radeon™ Vega Graphics/ Ryzen™ 1st Generation Processors :
1 x M.2 Socket 3, with M key, type 2242/2260/2280/22110 storage devices support (SATA & PCIE 3.0 x 4 mode)*2

AMD B450 chipset :
1 x M.2 Socket 3, with M Key, type 2242/2260/2280 storage devices support (PCIE 2.0 x4)*3
 

The_BlackHusky

Commendable
May 29, 2017
6
1
1,515
0
One port supports both SATA and PCIe drives.
The other supports only PCIe.

Your WD Blue is a SATA M.2 drive.
Which port do you have the drives in?


AMD Ryzen™ 2nd Generation/ Ryzen™ with Radeon™ Vega Graphics/ Ryzen™ 1st Generation Processors :
1 x M.2 Socket 3, with M key, type 2242/2260/2280/22110 storage devices support (SATA & PCIE 3.0 x 4 mode)*2

AMD B450 chipset :
1 x M.2 Socket 3, with M Key, type 2242/2260/2280 storage devices support (PCIE 2.0 x4)*3
Ah okay, I didnt even know to look for that information when putting it all together. Currently, The WD Blue is in slot 2 on the board. While the Corsair mp510 is in slot 1. When I get time I will swap them later today. Thank you.
 

The_BlackHusky

Commendable
May 29, 2017
6
1
1,515
0
One port supports both SATA and PCIe drives.
The other supports only PCIe.

Your WD Blue is a SATA M.2 drive.
Which port do you have the drives in?


AMD Ryzen™ 2nd Generation/ Ryzen™ with Radeon™ Vega Graphics/ Ryzen™ 1st Generation Processors :
1 x M.2 Socket 3, with M key, type 2242/2260/2280/22110 storage devices support (SATA & PCIE 3.0 x 4 mode)*2

AMD B450 chipset :
1 x M.2 Socket 3, with M Key, type 2242/2260/2280 storage devices support (PCIE 2.0 x4)*3
Problem resolved with swapping them over. Thank you for the information :p
 
Reactions: USAFRet

ASK THE COMMUNITY

TRENDING THREADS