WD Caviar Green EZRX 3TB hard disk detected in BIOS but not in device manager


Jun 22, 2013

So i had recently purchased WD caviar green 3tb hard disk (EZRX). I installed it in my NZXT gamma and completed all the necessary connections. Boot into windows 8.1 and went to Disk Management for initializing the new drive. Initialized it with GPT partitioning and made one 2.7 TB partition out of it.

Now the partition is visible initially at that time. Then i tried to move some 160 GB odd data from D to newly created F partition. Here i start to experience my first issue. This issue is that when the windows is transferring the data it sometimes go to 0 bytes/sec speed and remain there for nearly 10 minutes and then start transferring at regular 70 MBps and then again goes to 0. So this happens alternatively with out any fixed duration.

Fed up from this i decided to reboot the system and here comes the second problem.
Hard disk is now visible in the uefi BIOS but not in MY computer or Disk Management or Device Manager at all. I have even tried to test the drive on different sata ports but to no success.
Tested the existence of the drive in HD tune pro but again no drive found. I have downloaded the official WD diagnostic tool and even that tool is unable to detect the HDD.

After fruitless hours of trying different options i have found this option in Device Manager named 'Show Hidden Devices'. I clicked on it and the drive i was searching so hard immediately appears under Sata section.

So could any one please help me in understanding why this new drive is under hidden category and how to correct it. Should i RMA the drive?

I also want to add that while creating some new text file for the first time in that 2.7 tb partition it takes unusual amount of time to create the file approx 1 minute.

neon neophyte

Apr 11, 2009
sorry., didnt fully read and i dont see the delete option. you seem to know what you are doing so there is definitely some strange problem here. either the drive itself or the controller it is on. im going to assume it is on the same controller as another drive, so i really dont know.

Similar threads