WD External 1TB drive shows "device not ready"


Aug 16, 2015
I have a WD 1TB External ULTRA Drive. Prior to yesterday, it worked fine on my laptop running Windows 7. Last night I attached it to my SMART TV, thinking it would be accessible there. It was not. Since then, when I re-attach it to my laptop, the indicator light on the drive stays solid, is NOT recognized by Windows Explorer

So far I have tried these options:

DISK Manager sees is as a device but its UNALLOCATED. When I try to initialize it, it comes back with DEVICE NOT READY.

DEVICE MANAGER sees the drive ok.

For whatever reason hooking it up to the TV somehow screwed something up. I have done numerous reboots, power off, several utilities from MS and WD all to no avail.

NOTE I DO NOT have access to any other computers. I assume the cable is fine because although Windows Explorer won't mount it, the other utilities see it, but do not know what it is.

Welcome to the community, Kiernanjp!

I'm sorry to hear about your WD Passport Ultra drive. Unfortunately, sometimes connecting the external to a different operating system or device (like your Smart TV) messes up the file system. However, I'd suggest you to try uninstalling and re-installing the WD Passport from Device Manager ( http://technet.microsoft.com/en-us/library/cc725782.aspx ) After a reboot, plug and play the external and wait until it installs the utilities again.
Another thing you can try is assigning a different drive letter to the HDD through Disk Management. Here's a tutorial from our KB that explains how to do that: http://products.wdc.com/support/kb.ashx?id=esHghV

Keep me posted! Hope it helps though.

Similar threads