• Hey there, Guest! Share your idea for a new trophy in the forums and win bragging rights and a $100 Amazon gift card! Check out the New Community Trophy Contest here!
  • Pardon our dust as we work on some regularly scheduled forum maintenance. You may notice some missing features during this time. Thank you for your patience!

WD external Hard Drive wont load, slows the whole pc.

AlphaMike

Reputable
Dec 16, 2015
4
0
4,510
0
Hello everyone,
I have a problem with my external hard drive.
When i plug it in it shows up in my computer after a while bit i wont show the green bar that indicates the free space, also the green bar above load very slow and stuck right before the end.
If i try to right click it start loading( the blue circle appears) and after a whiles its no responding and window explorer restarts.
I tried diskpart from cmd it stuck too.
when i try to safe eject nothing happens.
A recovery software i have for hard drives wont even open if the drive is plugged.
Same thing with Testdisk 7.0.
I run windows 7 64bit

Any ideas?
 
Hi there AlphaMike,

That is really unpleasant. :(

Is the drive under warranty?

Do you have some data stored over there? As the drive can't really be accessed by Win tools, then I believe you can try to access the drive under Ubuntu: http://www.tomshardware.co.uk/forum/267999-32-recover-data-mode
You will need a CD or a flash drive so you can boot Ubuntu. Then you can navigate to the drive and back up all the data in case it is accessible.

After that, you can switch back to Win and try to test the drive with WD's DLG tool (short and extended tests): http://products.wdc.com/support/kb.ashx?id=qEGS5j

You can try something simple as just attaching the drive with another cable to a different USB port.

Cheers,
D_Know_WD :)
 

AlphaMike

Reputable
Dec 16, 2015
4
0
4,510
0


Thank you for your reply, i will try your solution as soon as i can and i ll report back.
 
Apr 18, 2017
1
0
510
0
Did it ever work? I am currently having the exact same problem.




 

Similar threads