• Hey there, Guest! Share your idea for a new trophy in the forums and win bragging rights and a $100 Amazon gift card! Check out the New Community Trophy Contest here!
  • Pardon our dust as we work on some regularly scheduled forum maintenance. You may notice some missing features during this time. Thank you for your patience!

WD HFS external hard drive won't change from read-only to read and write, tried opening the padlock already

Richard_163

Commendable
Sep 9, 2016
1
0
1,510
0
External hard drive WD formatted in Mac OS Extended changed to Read-only by itself, can't reformat until the files are recovered, Disk Utility does nothing, opened the padlock and the options are still grayed out, tried the dot_clean but get permission denied, could back up some of the files but others won't move back to my desktop. Hope someone knows the answer to this.
 
Welcome to the TH Community, Richard!

This sounds pretty unfortunate! DO you use the external on any other computer system or device? I'm sorry to hear about your issues with the WD external. though. If by opening the padlock, you mean opening the external case of the drive, I'd suggest you put it back in and attempt to access it again. Some of our external models incorporate a hardware-based encryption that prevent you from accessing the file without the original enclosure. Moreover, tampering with the drive physically voids the warranty! :(
I'd suggest you start by attempting to detect any defects on the drive through the Disk Utility. Afterwards, try to correct the permissions through there again. Posting some screenshots with the errors would be helpful, too.
Make sure you backup all your data as soon as you can access it!

Keep me posted.
SuperSoph_WD
 

Similar threads