[SOLVED] WD My Passport Ultra Stopped Working

Oct 26, 2019
Hey Everyone!

This is my first post on the forum and I really need your help!

I was arranging and moving files from, to and within my WD external hard drive and at some point I attempted adjusting its partitions.

The operation was interrupted halfway through and I think this messed up the drive.

Now, when I plug it in Windows 10 laptop, the explorer stops responding for a long while, then it shows the two partitions on the drive without any information about storage space. And If I try to access the partitions, explorer crashes.

Also, in the task manager, it appears that the drive is being used at full capacity by "System".

I tried plugging it into another PC, same things happen.
I also tried used chkdsk to no avail.

I reckon it has to be formatted for everything to get working again, but before I do that, I'd like to recover my files.

I am pretty certain all files are recoverable but the problem is no recovery tool is able to recognize the drive.

Can anyone please help me! I'm really out of ideas and solutions!

Best regards