WD Passport Ultra not mounting on Macbook Pro

Sydney_1

Commendable
Jul 16, 2016
1
0
1,510
My WD Passport Ultra is not opening into my time machine, along with my screen. I tried to download the diagnostics, changing the port, nothing has worked. This is a 4 month old external hard drive with a 1 TB - the lights are turned on showing the cable must be working, I just cant seem to make it work!!
does any one know how? It just seemed to stop working 4 days ago.

Thanks so much in advanced!!!
 
Hey there, Sydney. Welcome to tom'sHARDWARE!

Sorry to hear about the issues you've been experiencing with your drive. :(

Did anything in particular happen before the drive stopped working?
Even if the lights are on, I'd still advise you to try it out with a different USB cable and see if the same thing happens. It would be even better if you could give it a go with another computer as well. Since you're using it with time machine I assume that you have backup copy of the data that's on it, but please correct me if I'm wrong. So if this is the case, you should try testing it for errors by following this tutorial: How to test a drive for defects or problems on a Mac.

Hope that helps. Please let me know how it goes.
Boogieman_WD
 

ASK THE COMMUNITY

TRENDING THREADS