Question Webpage stuck at "Checking if the site connection is secure" screen ?

Steven Mal

Distinguished
Jun 8, 2013
91
0
18,630
0
I apologize because I don't know exactly which forum this thread belongs in. In the past I have used the web browser on my LG OLED 65B7A TV to watch videos on wcoforever.net. The browser, website and videos have always worked flawlessly until now. For the first time ever, whenever I click on a link to another webpage from the homepage, the next webpage presents a screen that says "Checking if the site connection is secure. www.wcoforever.net needs to review the security of your connection before proceeding." and does not stop loading or move onto the next webpage. Effectively, the website's links, excluding the homepage, are stuck loading at this screen, the same page, and it is impossible to watch any videos. The software version is 06.10.30 and is up to date. Strangely, wcoforever.net works perfectly on my computer but I would prefer to use my TV. Why am I seeing this new notice that doesn't stop loading or go to the next webpage? How can I get rid of it to continue using the website? Thank you.
 

Colif

Win 11 Master
Moderator
Jun 12, 2015
61,162
5,187
166,290
10,454
have you tried clearing cookies on the website?

web browser on my LG OLED 65B7A
try clearing its cache and see if that helps?
  • From your Home screen, open the Web Browser app.
  • Then, click Menu > Settings.
  • In the settings, you can toggle the Private Browsing button to On if you want to avoid accumulating so much browsing data in the future.
  • Then, click on the Clear Browsing Data button to clear your cache and cookies.
  • Click OK to confirm.

Website - it seems to work fine, I didn't get any message about security

looks like a cloudflare error - https://community.cloudflare.com/t/getting-checking-if-the-site-connection-is-secure-message/407480
 
Last edited:
Reactions: Phillip Corcoran

ASK THE COMMUNITY

TRENDING THREADS