Question Webpage won't display correctly in any browser

Feb 5, 2020
3
0
10
0
Alright, so I'm having a problem. I have a website that will not load/display properly, no matter what browser I use. I've tried using Edge, Chrome, and Firefox. I reinstalled Flash and made sure java was enabled. I turned my antivirus off too and tested.

I can turn off the page style, and everything shows up, but when I turn it back on, it's back to not displaying correctly. I figure it has to be a windows 10 problem, it's the only thing I can think at this time, also since the last update I've noticed a few quirks lately, like my search bar being a bit flaky.

I have a friend who can display the page no problem, who uses chrome, or I would have thought it was the website its self having been poorly set up. Does anyone have any ideas or run into this problem?
 
If the website is not displaying properly on your computer but it works fine on others, then the issue could be within your system .
It could be poorly written website.
Did you try on Internet Explorer?
 
Last edited:

Lutfij

Titan
Moderator
I turned my antivirus off too and tested.
That is not a good idea. I've been tasked with reviving a system that seemed to be dead due to hardware issues, turns out it was infected by ransomware, so now the files that need recovering are bills, CAD layout and rendering that are necessary to pay off the workers and the project.

That's not happening.

With that story, mind sharing the site that you're trying to visit?

Which version of Windows 10 are you working with?
 
The website loading time is slower than other similar websites but it loads just fine.
I tried on 3 laptops and a desktops all with different versions of Windows 10 (1809/1903/1909/2004).
It loaded faster on Internet Explorer that any other browser (Chrome, Firefox & Edge)
Try updating your graphics drivers and also clear your temp and cache folders.
 

ASK THE COMMUNITY

TRENDING THREADS