[SOLVED] Weird CPU multiplier in AIDA64 Extreme

Oct 1, 2020
26
2
35
0
Hello, here is my system:
CPU: AMD Ryzen 7 3700x
MoBo: Gigabyte Aorus B550 Pro
PSU: Thermaltake PF1 650W
MoBo BIOS: F2
GPU: Nvidia geforce GTX 1050ti
RAM: Kingston HyperX kit 16 Gb (2x8Gb)
All cpu settings in BIOS set on Auto
AMD chipset driver is latest from MoBo page
Windows 10 Pro x64 2004
So the problem is i get weird CPU multiplier in AIDA64. It should be in range from x36 (3600Mhz - stock clock) to x44 (Turbo boost clock) but sometimes it goes lower than x36 (x35.2 or even x34.8 or around that). I tried to change my power plan to "AMD High performance for Ryzen" and it actually helped a bit, but it stil goes lower than x36 sometimes. Before that when i was using "AMD Balanced for Ryzen" power plan CPU multiplier was going lower way often. Beside that sometimes PC crashes on windows startup with BSoD (INTERNAL_POWER_ERROR 0xa0) which indicates that there is a problem with power policy manager (as i learned from google). Should i worry about my CPU multiplier?
 

Darkbreeze

Retired Mod
Of course it goes lower, and it is SUPPOSED to do that. That is CORRECT and normal behavior.

When people configure their core behavior so that cores never get a chance to "rest" they end up with an overall higher package temp and over the long term probably also shorten the life of the CPU to some degree. Those lower frequencies are the various power saving features like the lower power C states and Cool N Quiet working the way they are supposed to so that cores that aren't needed at the time get a chance to rest and so that long term cores get equal usage, or more equal usage anyhow, aside from the strongest core which will likely see more "on" time than other cores.

What you SHOULD do is make sure you have the MOST current motherboard BIOS version installed, the MOST current AMD chipset driver for B550 from the AMD website installed and set your power plan to either Balanced or AMD balanced, then make sure that the minimum processor power state for that power plan in it's advanced settings is set to 5% and the maximum to 100%. If you REALLY wanted to make sure it didn't drop below 3600mhz, which I don't recommend and which is NOT necessary, you could set that minimum power state to somewhere around 35-45%, playing around with the number until you achieve the desired frequency, but again, I don't recommend it.

Both Intel and AMD CPUs are DESIGNED to specifically make use of low power states between 5-100%, and the amount of time it takes a core to react and go from 5-100% is a matter of milliseconds, too fast for you to even notice when it happens, too fast in fact for the monitoring software to poll in real time, and you don't lose anything at all by having your system configured to run the full gamut from 5% at idle to 100% when under a load.
 

DMAN999

Reputable
Ambassador
My 3700x goes down to 2.25 GHz at idle with the Ryzen Balanced Power Plan (Min CPU state set at 20%).
When using the Balanced Power Plan it should drop below 3.6 Ghz at idle and only ramp up when needed.

I suggest that you run an SFC Scan:
  1. Go to Search > open Command Prompt > Run as administrator.
  2. Now enter the sfc/scannow command and hit Enter
  3. Wait for the whole process to complete (approx. 15 minutes) and restart your system.
 
Last edited:

Darkbreeze

Retired Mod
Of course it goes lower, and it is SUPPOSED to do that. That is CORRECT and normal behavior.

When people configure their core behavior so that cores never get a chance to "rest" they end up with an overall higher package temp and over the long term probably also shorten the life of the CPU to some degree. Those lower frequencies are the various power saving features like the lower power C states and Cool N Quiet working the way they are supposed to so that cores that aren't needed at the time get a chance to rest and so that long term cores get equal usage, or more equal usage anyhow, aside from the strongest core which will likely see more "on" time than other cores.

What you SHOULD do is make sure you have the MOST current motherboard BIOS version installed, the MOST current AMD chipset driver for B550 from the AMD website installed and set your power plan to either Balanced or AMD balanced, then make sure that the minimum processor power state for that power plan in it's advanced settings is set to 5% and the maximum to 100%. If you REALLY wanted to make sure it didn't drop below 3600mhz, which I don't recommend and which is NOT necessary, you could set that minimum power state to somewhere around 35-45%, playing around with the number until you achieve the desired frequency, but again, I don't recommend it.

Both Intel and AMD CPUs are DESIGNED to specifically make use of low power states between 5-100%, and the amount of time it takes a core to react and go from 5-100% is a matter of milliseconds, too fast for you to even notice when it happens, too fast in fact for the monitoring software to poll in real time, and you don't lose anything at all by having your system configured to run the full gamut from 5% at idle to 100% when under a load.
 
Oct 1, 2020
26
2
35
0
I suggest that you run an SFC Scan:
  1. Go to Search > open Command Prompt > Run as administrator.
  2. Now enter the sfc/scannow command and hit Enter
  3. Wait for the whole process to complete (approx. 15 minutes) and restart your system.
Thanks for your reply. I did that many times, no errors at all. I mean my pc works fine during daily use beside some BSoDs im getting on windows startup sometimes.
 
Oct 1, 2020
26
2
35
0
Of course it goes lower, and it is SUPPOSED to do that. That is CORRECT and normal behavior.

When people configure their core behavior so that cores never get a chance to "rest" they end up with an overall higher package temp and over the long term probably also shorten the life of the CPU to some degree. Those lower frequencies are the various power saving features like the lower power C states and Cool N Quiet working the way they are supposed to so that cores that aren't needed at the time get a chance to rest and so that long term cores get equal usage, or more equal usage anyhow, aside from the strongest core which will likely see more "on" time than other cores.

What you SHOULD do is make sure you have the MOST current motherboard BIOS version installed, the MOST current AMD chipset driver for B550 from the AMD website installed and set your power plan to either Balanced or AMD balanced, then make sure that the minimum processor power state for that power plan in it's advanced settings is set to 5% and the maximum to 100%. If you REALLY wanted to make sure it didn't drop below 3600mhz, which I don't recommend and which is NOT necessary, you could set that minimum power state to somewhere around 35-45%, playing around with the number until you achieve the desired frequency, but again, I don't recommend it.

Both Intel and AMD CPUs are DESIGNED to specifically make use of low power states between 5-100%, and the amount of time it takes a core to react and go from 5-100% is a matter of milliseconds, too fast for you to even notice when it happens, too fast in fact for the monitoring software to poll in real time, and you don't lose anything at all by having your system configured to run the full gamut from 5% at idle to 100% when under a load.
Thank you for detailed answer. After I installed latest AMD Chipset driver from mobo page (for some reason they have higher version than one on AMD site) it automatically set power plan to "AMD Balanced for Ryzen", but the minimum state was 99% and maximum state was 100%. Should I change it to 5% and 100%?
 

Darkbreeze

Retired Mod
This core behavior and the fact you are getting some random errors, are exclusively separate issues, most assuredly.

Don't use the chipset driver from the motherboard page. Use the latest version from the AMD website.

Use the drivers for LAN/Ethernet and audio, plus wireless or blu tooth drivers if any apply, from the motherboard page.

Also, you are way behind on BIOS updates, and there are memory, PCIe device and CPU microcode issues addressed by newer versions. I'd update to F10 immediately.
 
Oct 1, 2020
26
2
35
0
Don't use the chipset driver from the motherboard page. Use the latest version from the AMD website.
Would it be enough if I remove my current chipset driver through control panel and just install driver from AMD website? Or there is some sort of clean install like you should do with GPU drivers?
 

ASK THE COMMUNITY

TRENDING THREADS