Weird game quirks - Vista 64 bit or my video card?


Oct 4, 2008
I recently got myself a Radeon 4850 and decided to upgrade to 64 bit Vista (had 32 bit previously). My previous graphics card was an NVIDIA 8600 GT. After installing 64 bit Vista + the Radeon 4850 I noticed several problems with some of my games.

1. Counter-Strike 1.6
Whenever I minimize the game it would automatically close it (forcing me to open up the game again). I changed the video mode to D3D instead of OpenGL and the problem was fixed.

2. Crysis: Warhead
On 32bit Vista it ran fine, DX10 + fullscreen mode, everything. After putting it on 64bit Vista however, the game would open up in windowed mode using DX10. Setting it to fullscreen in-game or using alt+enter would cause the screen to go black and all I'd see is the cursor (which was updated to the in-game cursor). I even waited a long time hoping it'd fix itself. What's weird though is setting it to DX9 enables me to play the game in full screen. As of now I leave it at DX9 so I can play in fullscreen at any resolution.

3. Assassin's Creed
On 32bit Vista it ran fine in DX10 + fullscreen mode. On my 64bit OS it now fails to load in DX10 mode (I think because it starts fullscreen rather than windowed) but will run just fine with DX9.

4. Bioshock
Updated: Got it to work in windowed mode. Again it fails to load properly (get an error) when it is fullscreen + DX10.

5. S.T.A.L.K.E.R Clear Skies
Ran this game it worked fine but when switched to DX10 in fullscreen mode it wouldn't start properly. Had to reinstall the game to get it back to DX9 because I couldn't find where the game options save to. Again when I switched to non-fullscreen in DX10 mode it works fine.

Note for each of the games running DX10 in fullscreen, the screen would just go black and I'd have to go to task manager or press the ESC key several times to close out of it.

Unfortunately I got my new video card and installed 64 bit Vista right after. I didn't get a chance to try out these games under 32 bit. Looking up the problem on google yielded results but no solutions ( ). I tried several other search queries but couldn't come up with anything. I thought it might be easier to ask on the forums.

Quick Breakdown
■Isolated to DirectX 10 games
■DirectX 10 games work only in windowed mode
■All DirectX 9 games work in fullscreen/windowed mode
■Somehow when Counter-Strike 1.6 is minimized when using OpenGL, it closes completely (where using D3D mode it works fine).
■Under 32 bit Vista + using an NVIDIA 8600GT all games worked as expected.

Before you guys reply, here are a few things I've tried:

What I've tried
■Downloading latest drivers from AMD's website (last updated Sept. 17th, 2008)
■Contacting ATI about the issue for feedback
■Googled for a solution
■Downloading/installing DirectX SDK + ensuring I have latest version installed
■Having all windows updates installed
■Disabling Tablet PC Optional Components in Vista (was posted a solution to get Bioshock running properly)

So what do you guys think? A problem with 64 bit Vista or the Radeon 4850 graphics drivers? Has anyone experienced any similar problems or know of a solution? For most of these issues there are workarounds but it is annoying without a real solution.
I have a quirk on warhead too - the black screen and a frozen cursor - I forget all the details. I also get a funny thing where the mouse cursor is not where it 'appears' - in other words I can have it over a certain maenu item and that menu item will not activate but if I move the cursor over a few inches it will activate - same thing in game, it won't shoot where I am aiming. If I hit ctr+alt+del and then CANCEL instead of going into task manager it will correct this problem. I do this every time.

Not sure where these quirks originate, Vista, Vista +64, or vista + DX 10?
I'm using an Nvidia card BTW.


Apr 27, 2009
I have same problem as original poster. I'm running ATI 4850 with Vista Ultimate 64 w/service pack 1 installed:

Driver Packaging Version 8.573-090113a-074234C-ATI
Catalyst™ Version 09.1
Provider ATI Technologies Inc.
2D Driver Version
2D Driver File Path /REGISTRY/MACHINE/SYSTEM/ControlSet001/Control/CLASS/{4D36E968-E325-11CE-BFC1-08002BE10318}/0000
Direct3D Version
OpenGL Version
Catalyst™ Control Center Version 2009.0113.2222.40119

Guild Wars: Windowed only, no full screen
Mirror's Edge: Blank screen (with background music). I assume it's in full screen mode but I can't get out of it either.


Feb 10, 2009
Just to add my 2cents... I'm currently re-installing a dual-boot Vista Business x64 &32 because the current x64 Radeon 4800 drivers are shitty at best... I was at the point where i was getting 0x0000000124 every time!! I know that it was these drivers because an impromptu Vista 32 install revealed that the 32-bit drivers are fine... many others out there have reverted to CCC 8.9 and the driver package like 8.4..... (something)... you will lose some of the nice features, but your best bet is to be patient, file a request with ATI, dual-boot Vista 32 (if possible)

**The windows update drivers will BSOD your machine, instantly; appartnetly M$ combined the CCC 8.9 driver pack with the wrong 2d drivers, as soon as CCC loads your done***

Keep checking for a fix...


Jun 22, 2009
My problem is similar but not identical.

My rig's specs:
X58 MoBo - i7 920 @ 2.67 GHZ; 1GB XFX/1GB Sapphire ATI 4850 CrossFire;700 W PSU; 8 GB Corsair DDR3 12800 RAM; Seagate 750 GB HD SATA II: Samsung SyncMaster T260 25.5" flatpanel.

I have catalyst control center version 9.6 loaded on my rig. Games I play are Crysis, Crysis Warhead, Sins of a Solar Empire, End War, WIC, C&C Tiberium Wars, Mass Effect, etc. I have no problems playing any of these games at 1920X1080 resolution with either ultra high or high settings (depending on the game, e.g., I have Crysis set at"high" for everything).

However, I can only play these games at the mentioned settings in Windows Mode only. If I switch to fullscreen mode, I have major problems such as white horizontal jagged lines running up and down my flatpanel (it's not screen tearing). When I play in Windows problems with artifacts, jagged lines or anything. The games run very smoothly.

Any help to fix this "fullscreen" problem will be greatly appreciated.


Aug 28, 2009

zmanster- I have almost exactly the same problem.

I just bought a brand-new ASUS gaming rig:

quad-core i7s, 9 gigs of DDR3 RAM, nvidia GeForce GTX 260 GPU, 1 TB Hard Drive, and Windows Vista 64-bit.

At first FarCry 2, BioShock, and Oblivion all ran perfectly for hours at a time with maxed-out graphics. Then, yesterday, none of them would work- they were incredibly slow or completely locked up. They play just fine in windowed mode, however, and also in Directx 9 mode.

Thing is, I have a Samsung monitor too, and these issues began happening after I added the monitor drivers and some of the peripherals off of the cd that came with it. My monitor is a P2070, but I'm wondering if it could be a Samsung driver interferring with Directx 10? Did you fix your issue? Did you load that driver off of the CD, or continue to use your monitor as a generic Plug and Play?


Sep 23, 2009
zmanster and Olaus,
I have the solution for your problem! (which was my problem too).
You need the VSYNC option to be turned on. That's what will stop the jagged line/screen tearing.
It should be turned on from the graphics card driver, or from the game itself. The thing with Windows Vista/7 is that it's doing problem with this option from some reason. The solution is here: (read the first post, it's enough).

The funny thing about all this is that I had to turn back to the good old Windows XP to find out about it... But anyway, I think that I'll stick with it. :)

Good luck!


Mar 15, 2010
i have the same problem with my 64bit vista premium with all DX10 games: mostly the full screen hassle. If not that then an off center mouse problem that irritates the heck out of me because menu tabs are often too far to the right and the mouse spins uncontrollably if i get in-game at all (up and to the left). Tried the tablet pc fix as well in the control panel Admin tools and services. I noticed Olaus mentioned a monitor...hmm... do any of you happen to be running a 16x9 dimension monitor/screen? Thin and long if you don't know what i'm talking about, good for movies. I tried playing on my TV (which is 16x9 as well) and my new Acer P244w, also 16x9. games i've been having trouble with are Red Faction: Guerrilla (windowed & mouse), Shattered Horizon (mouse), Bad Company 2 (mouse), Eve Online (windowed & mouse). A flip or hack to force Dx9 fixes all this. i got an Asus p5ne-sli with 2x 8800gs (drivers up to date); 4gb Sli OCZ nvidia ram 6400; logitech board and mouse G5 (don't ask, but this mouse almost went out the window); 2x 250gb hdd's in RAID 0 with vista home premium 64bit;


Mar 15, 2010
try changing the dpi settings in your windows back to normal size. This fixed it for me, i did not even remember changing it to large long ago to read stuff better. Goodluck.