Question Weird issue when trying to access bios

avioncumotor

Prominent
Sep 7, 2019
48
2
535
0
Hey there,

Just let me start by prefacing that this is not my strong suite :)

CPU: 7 2700x
Motherboard: msi b450
Ram: 16 hyperx 3333
SSD/HDD: ssd 500
GPU: 2070 super
PSU: 850x corsair
Chassis: -
OS: win10

So today I tried accessing the bios like I usually do, pressing the Delete key, but must say i have not gotten into bios in maybe more than 1 year, so on the 1st attempt after restarting the PC and pressing Del, windows would say restarting, the screen would go dark, the LED on the mobo would flash like they should, but then there is no signal going to the monitor, but the PC never shut itself down, even for a second. I thought let me try another key, and i tried f11, 12, etc, and it seemed to do the same thing. Basically if I press most keys during a restart, the computer won't restart but just sit in this limbo phase.

I have then, randomly tried pressing ctrl alt del which makes again 2 LED on the mobo pop red and the PC restarts absolutely normally (If i don't press anything else). This is weird to me, as no idea why that would randomly turn my PC on from that limbo state.

The only major thing that changed in this pas year is spilling water on my keyboard, and having then a play with the Bios button on the back of it which has 4 options 1-2-4-8 and is currently sitting on an 8.

I tried turning off that fast power option that a read a lil bit online about, but same thing happened.

Any idea, however small or big would be much appreciated as I'm completely lost to how I can get into bios :)

Help a brother set a fan curve that does not wake up my whole flat
 

avioncumotor

Prominent
Sep 7, 2019
48
2
535
0
Thanks mate, ill give it a go, but really weird behaviour as I have not change/updated anything. And maybe just for my own knowledge, any clue why the alt ctrl del would kick-start the restart?
 

jay32267

Glorious
I could be the CMOS battery is weak.
Strange things can happen with a weak CMOS battery.
You might consider replacing that when you clear the BIOS.

" any clue why the alt ctrl del would kick-start the restart? "
Not sure why....but I've had the same thing happen.
 

avioncumotor

Prominent
Sep 7, 2019
48
2
535
0
Hey mate,

So I finally got round to popping out the battery, and to my surprise it works, I can get into the bios, but another weird thing happened where the whole bios is not in Chinese :)

I kind of gave up on the fan curve at this point as i see this is a consistent issue with MSI and I'd have to get my bios to a previous version which I'm not the most comfortable doing. If you'd have any suggestions I'm all ears!

On a side note, another mysterious thing is happening when I launch DOTA2, my main display looses signal, my 2nd display stays on but freezes on the current image. The PC stays on like nothing happened, but it responds to nothing apart from a forced restart. This happened prior to flashing the CMOS, so not related to that, but just noticed it today so I'd thought I'd see if you might have any idea.

Much appreciated!
 

ASK THE COMMUNITY