Question Weird issue with computer bios resetting when power is lost

May 8, 2022
2
0
10
0
The computer is: Asus P6T (x58, socket 1366), Xeon x5675 (oc at 4,29), 24 GB of ram, 2 SSD, 4 HDD, XFX RX 570 4GB, Corsair TX650M (brand spanking new).

The issue: When I turn the computer off, and unplug it from socket (or press the switch on PSU), on the next boot all the bios settings are lost (date and time also). And I have to set everything up again.

When did it start to happen: silly me tried to clean the computer from dust, and tried (successfully) to flash a meltdown patched bios (I reverted to the old original one since). Cleaning from dust was made with a vacuum cleaner, and after the problems started everything was additionally cleaned with isopropanol (and repasted of course).

Tried to replace MBO battery (5 brand new ones, from different manufacturers), and it didn’t help. Please do not suggest this.

I have deduced that some sort of a problem persists between the MBO and GPU. GPU was tested in 2 alternate computers, and does not create the same issue in them.

Motherboard was tested with different RAM and different GPU (old Nvidia 9800GT 1GB), and it works normally without the issue.

The problem seems to persist only with P6T + RX 570, which is driving me crazy since this setup worked without issues for 3 years before. I have tried everything I could think of, but with no success. And it's so insanely annoying.

Any ideas, what could be the issue, or how to fix it?

p.s. when I set all the bios settings and boot, computer passes all the stress test i give it with flying colors: 1h OCCT CPU, 1h OCCT RAM, 1h Heaven benchmark.
 

ASK THE COMMUNITY