• Find an incredible deal for Black Friday or Cyber Monday? Share those epic bargains with the community by posting them in this forum thread!

Question Weird issue

Nov 15, 2019
8
0
10
0
So I had just upgraded from a 3770k to a 3700x. For 2 days everything was working fine until I woke up today and the pc won’t boot.

I’m getting no beeps and instead the RGB from the mobo starts up but none of my case fans begin to spin. Also clicking the power button on the front of the case does nothing.


My sadness is very large please help.
 
Nov 15, 2019
8
0
10
0
What is your EXACT power supply model and how long has it been in service?

What are your FULL hardware specifications including the model numbers of your other hardware?
Oh boy uh it’s a Corsair 850 and it’s maybe 5-6 years old. Got an X570 steel legend mobo, 16gb tridentz ram 3200. 3700x with the stock wraith prism cooler. And 2 ssds with a 3rd nvme that I wasn’t able to get detected but I’ll save that issue for later.
 

Darkbreeze

Titan
Moderator
So, the first thing to do is disconnect ALL of the connections to the motherboard from the front case I/O panel and then try jumping the pwr+ and pwr- connections on the motherboard that the power switch normally connects to with the tip of a flat screwdriver.

If you get nothing, then there are few options but first you should go ahead and restore the front panel connections to the motherboard since the switch was not the problem. If it was, then replace the switch.

When you power the unit on, does the PSU fan come on?

Try this and see if the PSU fan is coming on at all.

View: https://www.youtube.com/watch?v=ixcWCrYpw3Y
 
Nov 15, 2019
8
0
10
0
So, the first thing to do is disconnect ALL of the connections to the motherboard from the front case I/O panel and then try jumping the pwr+ and pwr- connections on the motherboard that the power switch normally connects to with the tip of a flat screwdriver.

If you get nothing, then there are few options but first you should go ahead and restore the front panel connections to the motherboard since the switch was not the problem. If it was, then replace the switch.

When you power the unit on, does the PSU fan come on?

Try this and see if the PSU fan is coming on at all.

View: https://www.youtube.com/watch?v=ixcWCrYpw3Y
I’ll give it a try and post results. My psu fan was spinning
 

ASK THE COMMUNITY

TRENDING THREADS