Question Weird monitor problem, flashing lines and black screens ?

Feb 15, 2021
4
0
10
0
So I recently switched my monitor connection from my graphics card ( no longer have) to my motherboard through HDMI. I started getting these flashing greenish/static horizontal lines across my screen and then the entire screen goes black for a few seconds then back on and sometimes does this multiple times continuously. This happens randomly throughout the day when in use but ALWAYS during bootup and during/after logging into windows. Here's a video of what it looks like
View: https://www.youtube.com/watch?v=2VSi42XqDlM&feature=youtu.be



I've tried different HDMI cables, updated and rolled back my display adapter driver, tried different ports on my motherboard. The strange thing is that if I connect my computer to my tv it works fine, and conversely if I connect my laptop to my monitor that works fine as well.

I've searched for hours for a fix and am completely lost. Any help would be appreciated

Specs I5 6600k

Gigabyte z170N - wifi

Silverstone 450w SFX bronze

16gb ddr4

Monitor : Asus Va32aq
 
Feb 20, 2021
3
0
10
0
It's strange that I have a similar problem on my Mac pro I use for work.

Sometimes the screen of the Mac and connected monitors go black for few seconds. This is driving me mad.

Have you or anyone found a solution?
 

TheJoker2020

Proper
Oct 13, 2020
198
45
120
17
So I recently switched my monitor connection from my graphics card ( no longer have) to my motherboard through HDMI. I started getting these flashing greenish/static horizontal lines across my screen and then the entire screen goes black for a few seconds then back on and sometimes does this multiple times continuously. This happens randomly throughout the day when in use but ALWAYS during bootup and during/after logging into windows. Here's a video of what it looks like
View: https://www.youtube.com/watch?v=2VSi42XqDlM&feature=youtu.be



I've tried different HDMI cables, updated and rolled back my display adapter driver, tried different ports on my motherboard. The strange thing is that if I connect my computer to my tv it works fine, and conversely if I connect my laptop to my monitor that works fine as well.

I've searched for hours for a fix and am completely lost. Any help would be appreciated

Specs I5 6600k

Gigabyte z170N - wifi

Silverstone 450w SFX bronze

16gb ddr4

Monitor : Asus Va32aq
Is the graphics you are using the Intel i5 integrated graphics.?
 

TheJoker2020

Proper
Oct 13, 2020
198
45
120
17
It's strange that I have a similar problem on my Mac pro I use for work.

Sometimes the screen of the Mac and connected monitors go black for few seconds. This is driving me mad.

Have you or anyone found a solution?
Go black for a few seconds and then it is fine, or is it like the above video with it going black on and off constantly.?
 
Feb 15, 2021
4
0
10
0
Do you by any chance have a Graphics Card you could install to test with.?
I did but I sold it. When the graphics card was plugged in, everything was fine. However when connecting directly from the motherboard is when it started to mess up. And just want to clarify that my screen is fine most of the time, it's just randomly it will glitch out like the video I posted above and does so for anywhere from 10 seconds or more, in which case either by turning the monitor on and off or unplugging and plugging the monitor from the PC helps fix it for a bit
 

TheJoker2020

Proper
Oct 13, 2020
198
45
120
17
I did but I sold it. When the graphics card was plugged in, everything was fine. However when connecting directly from the motherboard is when it started to mess up. And just want to clarify that my screen is fine most of the time, it's just randomly it will glitch out like the video I posted above and does so for anywhere from 10 seconds or more, in which case either by turning the monitor on and off or unplugging and plugging the monitor from the PC helps fix it for a bit
This is an odd problem.

Does this happen randomly, after a period of inactivity, when doing certain things or when the monitor has been on for some time.?

As you have already tried different cables, a different screen and this screen on another PC this is a real oddity.

I am going to guess that everything is fine at first and this only happens after the monitor has been on for some time.

I will get back to you tomorrow 👍
 
Feb 15, 2021
4
0
10
0
This is an odd problem.

Does this happen randomly, after a period of inactivity, when doing certain things or when the monitor has been on for some time.?

As you have already tried different cables, a different screen and this screen on another PC this is a real oddity.

I am going to guess that everything is fine at first and this only happens after the monitor has been on for some time.

I will get back to you tomorrow 👍
It always happens when first starting the computer right before the windows login screen and after logging in. It doesn't do it much or at all if the screen is idle. It seems like it's triggered by activity such as opening new windows or moving the mouse, it's hard to tell. When it does happens it usually happens a couple of times consecutively.

Thanks for your help
 
Feb 20, 2021
3
0
10
0
Go black for a few seconds and then it is fine, or is it like the above video with it going black on and off constantly.?
On my case, it goes black for a few seconds and then it's fine, it happens sometimes.

I guess it's related to the graphics card having one or more monitor connector to the macbook.

I just don't know how to prevent it from happening.
 

ASK THE COMMUNITY