Question Weird motherboard issue..?

Jan 2, 2021
2
0
10
0
Hi all, I'm new to PC building so maybe this issue isn't that special but I haven't seen anyone ask a similar question so here it goes.

I bought used parts to build a PC for my dad:
i5 3470,
gtx 660,
patriot ddr3 1600 mz 2x4gb
and GA-H61MA-D3V (rev. 2.0)
oh and a 700w chieftec PSU

And the pc didn't post.. kinda? It turned on, fans spinning and all, then turned off, then turned on again by itself and went to like a motherboard home screen? Had options like F12 for boot menu, END - Q-Flash .. etc. It didn't respond to my usb keyboard and after a while it black screened and was stuck there (didn't power off). I got a usb to PS2 adapter and tried again. And same thing happened, reboot, motherboard screen, black screen. Didn't respond to the keyboard.

Tried reseting/clearing CMOS, didn't help. My borther came over few weeks later with his PC, we were upgrading it, anyways he had a PC on the same socket and so we tested my parts with his. And well everything worked, my ram, my cpu, psu, gpu.. everything was fine. We didn't put his i7 into my motherboard because we were scared we will kill it. I connected his mobo speaker and if I remember correctly the code referenced something about RAM. But by then we knew my ram is fine and we also tried his (don't remember MHz) and the same beep code played.

So seems like the motherboard was dead. So I bought another (used) one and the PC works fine :) however curiosity got to me and I bought a 2nd gen cpu (i3), thought that maybe the bios wasn't updated or something and that's why it didn't work with the i5 3470.
And this is where it gets interesting/weird for me.
It didn't work.. but it didn't work differently.

Powered on, fans spinning.. turns off.. turns on (by itself) and then goes to like a bios screen (so not the motherboard screen like before) buuut it's empty.... it says bios on the top and something but there are no other information or options on the screen. This goes by quickly and the PC turns off and then goes into a power cycle, doesn't go to the bios screen again, just on and off, on and off...

Tested the CPU and it works fine.

Anyone has any idea what is happening? What is wrong with the board? Not as interested in fixing it as in just knowing what's wrong. Or maybe am I actually doing something dumb and it's not the board?
Sorry for long post, I'm bad at being concise :sweatsmile:
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

The moment I read a thread that has Chieftec mentioned in the thread body, I'm 99.99% certain that the PSU is the cause of the issue.

See if you can find a reliably built PSU which has at least 450W of power. Yes the Chieftec unit has a sticker that says it can deliver 700W of power but the innards of that PSU can only output maybe 250W of power, even less if it's as old as the processor.
 
Jan 2, 2021
2
0
10
0
Thank you for the welcome :)

But I believe you're wrong, as I said, we tested everything with my brother's parts, including his PSU... tho I admit his PSU was kinda weird.. but work with his old setup and works in the new so I think it's good. Also, wouldn't even 250W be enough to just power the motherboard and CPU?

And I'm kinda shocked you're saying Chieftecs are bad :O I read reviews that they are the best budget PSU, they don't appear on any blacklist and people say it is good... I'm consufed

Edit: and this PSU works with the new (used) board.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS